ToolPalettePath Property (ActiveX)

Sets the tool palette path.

Supported platforms: Windows only

Signature

VBA:

object.ToolPalettePath
object

Type: PreferencesFiles

The object this property applies to.

Property Value

Read-only: No

Type: String

The tool palette path.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_ToolPalettePath()
    'This example changes the tool palette path
    'and then sets it to its original string

    Dim pref As AutoCAD.AcadPreferencesFiles
    Set pref = AcadApplication.Preferences.Files

    Dim defToolPalettePath As String
    Dim changedToolPalettePath As String

    defToolPalettePath = pref.ToolPalettePath
    MsgBox "The current tool palette path is " & defToolPalettePath

    pref.ToolPalettePath = "c:\winnt;c:\temp"
    changedToolPalettePath = pref.ToolPalettePath
    MsgBox "The changed tool palette path is " & changedToolPalettePath

    pref.ToolPalettePath = defToolPalettePath
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ToolPalettePath()
    ;; This example changes the tool palette path
    ;; and then sets it to its original string
    (setq acadObj (vlax-get-acad-object))
    (setq pref (vla-get-Files (vla-get-Preferences acadObj)))

    (setq defToolPalettePath (vla-get-ToolPalettePath pref))
    (alert (strcat "The current tool palette path is " defToolPalettePath))

    (vla-put-ToolPalettePath pref "c:\\winnt;c:\\temp")
    (alert (strcat "The changed tool palette path is " (vla-get-ToolPalettePath pref)))

    (vla-put-ToolPalettePath pref defToolPalettePath)
)