Specifies the start point of the second extension line.
Supported platforms: Windows only
VBA:
object.ExtLine2StartPoint
Type: DimAngular
The object this property applies to.
Read-only: No
Type: Variant (three-element array of doubles)
A 3D coordinate representing the start point of the second extension line.
The ExtLine1StartPoint and ExtLine2StartPoint properties are equal to the FirstEndPoint and SecondEndPoint parameters from the AddDimAngular method. The extension lines are originally drawn from the FirstEndPoint and SecondEndPoint locations to the intersection of the dimension line. AutoCAD draws the dimension line as an arc between the extension lines.
VBA:
Sub Example_ExtLine2StartPoint() ' This example creates an angular dimension. It then changes ' the location of the ExtLine2StartPoint. Dim dimObj As AcadDimAngular Dim angVert(0 To 2) As Double Dim FirstPoint(0 To 2) As Double Dim SecondPoint(0 To 2) As Double Dim TextPoint(0 To 2) As Double ' Define the dimension angVert(0) = 0#: angVert(1) = 5#: angVert(2) = 0# FirstPoint(0) = 1#: FirstPoint(1) = 7#: FirstPoint(2) = 0# SecondPoint(0) = 1#: SecondPoint(1) = 3#: SecondPoint(2) = 0# TextPoint(0) = 3#: TextPoint(1) = 5#: TextPoint(2) = 0# ' Create the angular dimension in model space Set dimObj = ThisDrawing.ModelSpace.AddDimAngular(angVert, FirstPoint, SecondPoint, TextPoint) ZoomAll MsgBox "The current value of ExtLine2StartPoint is " & dimObj.ExtLine2StartPoint(0) & ", " & dimObj.ExtLine2StartPoint(1) & ", " & dimObj.ExtLine2StartPoint(2), vbInformation, "ExtLine2StartPoint Example" ' Change the start point of the second extension line FirstPoint(0) = 1: FirstPoint(1) = 4: FirstPoint(2) = 0 dimObj.ExtLine2StartPoint = FirstPoint dimObj.Update ' Return the start point of the second extension line ' Note that the return value is a Variant Dim retPnt As Variant retPnt = dimObj.ExtLine2StartPoint MsgBox "The new value of ExtLine2StartPoint is " & dimObj.ExtLine2StartPoint(0) & ", " & dimObj.ExtLine2StartPoint(1) & ", " & dimObj.ExtLine2StartPoint(2), vbInformation, "ExtLine2StartPoint Example" End Sub
Visual LISP:
(vl-load-com) (defun c:Example_ExtLine2StartPoint() ;; This example creates an angular dimension. It then changes ;; the location of the ExtLine2StartPoint. (setq acadObj (vlax-get-acad-object)) (setq doc (vla-get-ActiveDocument acadObj)) ;; Define the dimension (setq AngleVertex (vlax-3d-point 0 5 0) FirstPoint (vlax-3d-point 1 7 0) SecondPoint (vlax-3d-point 1 3 0) TextPoint (vlax-3d-point 3 5 0)) ;; Create the angular dimension in model space (setq modelSpace (vla-get-ModelSpace doc)) (setq dimObj (vla-AddDimAngular modelSpace AngleVertex FirstPoint SecondPoint TextPoint)) (vla-ZoomAll acadObj) (setq extLineStartPoint (vlax-safearray->list (vlax-variant-value (vla-get-ExtLine2StartPoint dimObj)))) (alert (strcat "The current value of ExtLine2StartPoint is " (rtos (nth 0 extLineStartPoint) 2) ", " (rtos (nth 1 extLineStartPoint) 2) ", " (rtos (nth 2 extLineStartPoint) 2))) ;; Change the start point of the second extension line (setq FirstPoint (vlax-3d-point 1 4 0)) (vla-put-ExtLine2StartPoint dimObj FirstPoint) (vla-Update dimObj) ;; Return the start point of the second extension line ;; Note that the return value is a Variant (setq retPnt (vlax-safearray->list (vlax-variant-value (vla-get-ExtLine2StartPoint dimObj)))) (alert (strcat "The new value of ExtLine2StartPoint is " (rtos (nth 0 retPnt) 2) ", " (rtos (nth 1 retPnt) 2) ", " (rtos (nth 2 retPnt) 2))) )