AddCone Method (ActiveX)

Creates a 3D solid cone with the base on the XY plane of the WCS.

Supported platforms: Windows only

Signature

VBA:

RetVal = object.AddCone(Center, BaseRadius, Height)
object

Type: Block, ModelSpace, PaperSpace

The objects this method applies to.

Center

Access: Input-only

Type: Variant (three-element array of doubles)

The 3D WCS coordinates specifying the center of the bounding box.

BaseRadius

Access: Input-only

Type: Double

The radius of the cone base. Must be a positive number.

Height

Access: Input-only

Type: Double

The height of the cone. Must be a positive number.

Return Value (RetVal)

Type: 3DSolid

A 3DSolid object as the newly created cone.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_AddCone()
    ' This example creates a cone in model space.
   
    Dim coneObj As Acad3DSolid
    Dim radius As Double
    Dim center(0 To 2) As Double
    Dim height As Double
    
    ' Define the cone
    center(0) = 0#: center(1) = 0#: center(2) = 0#
    radius = 5#
    height = 20#
    
    ' Create the Cone (3DSolid) object in model space
    Set coneObj = ThisDrawing.ModelSpace.AddCone(center, radius, height)
    
    ' Change the viewing direction of the viewport to better see the cone
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    ZoomAll
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AddCone()
    ;; This example creates a cone in model space.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the cone
    (setq center (vlax-3d-point 0 0 0)
          coneRadius 5
	         coneHeight 20)
    
    ;; Create the Cone (3DSolid) object in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq coneObj (vla-AddCone modelSpace center coneRadius coneHeight))
  
    ;; Change the viewing direction of the viewport to better see the cone
    (setq NewDirection (vlax-3d-point -1 -1 1))
    (setq activeViewport (vla-get-ActiveViewport doc))
    (vla-put-Direction activeViewport NewDirection)
    (vla-put-ActiveViewport doc activeViewport)
    (vla-ZoomAll acadObj)
)