SelectSubRegion Method (ActiveX)

Selects a set of cells in a table.

Supported platforms: Windows only

Signature

VBA:

object.SelectSubRegion wpt1, wpt2, wvwVec, wvwxVec, seltype, bIncludeCurrentSelection, rowMin, rowMax, colMin, colMax
object

Type: Table

The object this method applies to.

wpt1

Access: Input-only

Type: Variant

3D point in WCS specifying the first corner point of the window box selection.

wpt2

Access: Input-only

Type: Variant

3D point in WCS specifying the second corner point of the window box selection.

wvwvec

Access: Input-only

Type: Variant

3D vector in WCS specifying the view direction of the selection.

wvwxvec

Access: Input-only

Type: Variant

3D vector in WCS specifying the view orientation of the hit test.

seltype

Access: Input-only

Type: AcSelectType enum

The selection type.

  • acCrossing: Cross-selection type
  • acWindow: Window-selection type
bincludecurrentselection

Access: Input-only

Type: Boolean

  • True: Selected cells returned will include currently selected cells and newly selected cells.
  • False: Only newly selected cells are returned.
rowMin

Access: Output-only

Type: Long

The zero-based lower bound of row index.

rowMax

Access: Output-only

Type: Long

The zero-based upper bound of row index.

colMin

Access: Output-only

Type: Long

The zero-based lower bound of column index.

colMax

Access: Output-only

Type: Long

The zero-based upper bound of column index.

Return Value (RetVal)

No return value.

Remarks

The row and column index of the upper and lower bounds of the selected region are returned in rowMin, rowMax, colMin, and colMax.

Examples

VBA:

Not available

Visual LISP:

Not available