Creates a single line of text.
Supported platforms: Windows only
VBA:
RetVal = object.AddText(TextString, InsertionPoint, Height)
Type: Block, ModelSpace, PaperSpace
The objects this method applies to.
Access: Input-only
Type: String
The actual text to be displayed.
Access: Input-only
Type: Variant (three-element array of doubles)
The 3D WCS coordinates on the drawing where the text is placed.
Access: Input-only
Type: Double
The height of the text. Must be a positive number.
No additional remarks.
VBA:
Sub Example_AddText() ' This example creates a text object in model space. Dim textObj As AcadText Dim textString As String Dim insertionPoint(0 To 2) As Double Dim height As Double ' Define the text object textString = "Hello, World." insertionPoint(0) = 2: insertionPoint(1) = 2: insertionPoint(2) = 0 height = 0.5 ' Create the text object in model space Set textObj = ThisDrawing.ModelSpace.AddText(textString, insertionPoint, height) ZoomAll End Sub
Visual LISP:
(vl-load-com) (defun c:Example_AddText() ;; This example creates a text object in model space. (setq acadObj (vlax-get-acad-object)) (setq doc (vla-get-ActiveDocument acadObj)) ;; Define the text object (setq insertionPoint (vlax-3d-point 2 2 0) textString "Hello, World." height 0.5) ;; Create the text object in model space (setq modelSpace (vla-get-ModelSpace doc)) (setq textObj (vla-AddText modelSpace textString insertionPoint height)) (vla-ZoomAll acadObj) )