Reload Method (ActiveX)

Reloads the external reference (xref).

Supported platforms: Windows only

Signature

VBA:

object.Reload
object

Type: ExternalReference

The object this method applies to.

Return Value (RetVal)

No return value.

Remarks

When you reload an xref, the most recently saved version of the referenced drawing is loaded into the current drawing.

Examples

VBA:

Sub Example_Reload()
    On Error GoTo ERRORHANDLER
                          
    ' Define external reference to be inserted
    Dim xrefHome As AcadBlock
    Dim xrefInserted As AcadExternalReference
    Dim insertionPnt(0 To 2) As Double
    Dim PathName As String
    insertionPnt(0) = 1
    insertionPnt(1) = 1
    insertionPnt(2) = 0
    PathName = "c:/AutoCAD/sample/City map.dwg"
    
    ' Add the external reference to the block
    Set xrefInserted = ThisDrawing.ModelSpace. _
            AttachExternalReference(PathName, "XREF_IMAGE", _
            insertionPnt, 1, 1, 1, 0, False)
    ZoomAll
    MsgBox "The external reference is attached."
    
    ' Reload the external reference definition
    ThisDrawing.Blocks.Item(xrefInserted.name).Reload
    MsgBox "The external reference is reloaded."
    Exit Sub
ERRORHANDLER:
    MsgBox Err.Description
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Reload()
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
                         
    ;; Define external reference to be inserted
    (setq insertionPnt (vlax-3d-point 1 1 0)
          pathName (findfile ".\\Sample\\Sheet Sets\\Architectural\\Res\\STAIR1.dwg"))
    
    ;; Add the external reference to the block
    (setq modelSpace (vla-get-ModelSpace doc))  
    (setq xrefInserted (vla-AttachExternalReference modelSpace pathName "XREF_IMAGE" insertionPnt 1 1 1 0 :vlax-false))
    (vla-ZoomAll acadObj)
    (alert "The external reference is attached.")
    
    ;; Unload the external reference definition
    (vla-Unload (vla-Item (vla-get-Blocks doc) "XREF_IMAGE"))
    (vla-Regen doc :vlax-true)
    (alert "The external reference is unloaded.")

    ;; Reload the external reference definition
    (vla-Reload (vla-Item (vla-get-Blocks doc) "XREF_IMAGE"))
    (alert "The external reference is reloaded.")
)