AddSphere Method (ActiveX)

Creates a sphere given the center and radius.

Supported platforms: Windows only

Signature

VBA:

RetVal = object.AddSphere(Center, Radius)
object

Type: Block, ModelSpace, PaperSpace

The objects this method applies to.

Center

Access: Input-only

Type: Variant (three-element array of doubles)

The 3D WCS coordinates specifying the sphere center point.

Radius

Access: Input-only

Type: Double

The radius of the sphere. Must be a positive number.

Return Value (RetVal)

Type: 3DSolid

A 3DSolid object as the newly created sphere.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_AddSphere()
    ' This example creates a sphere in model space.
    
    Dim sphereObj As Acad3DSolid
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    
    centerPoint(0) = 5#: centerPoint(1) = 5#: centerPoint(2) = 0#
    radius = 5#
    Set sphereObj = ThisDrawing.ModelSpace.AddSphere(centerPoint, radius)
        
     ' Change the viewing direction of the viewport
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    ZoomAll

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AddSphere()
    ;; This example creates a sphere in model space.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the solid sphere
    (setq centerPoint (vlax-3d-point 5 5 0)
          radius 5)
  
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq sphereObj (vla-AddSphere modelSpace centerPoint radius))
        
    ;; Change the viewing direction of the viewport
    (setq NewDirection (vlax-3d-point -1 -1 1))
    (setq activeViewport (vla-get-ActiveViewport doc))
    (vla-put-Direction activeViewport NewDirection)
    (vla-put-ActiveViewport doc activeViewport)
    (vla-ZoomAll acadObj)
)