AutomaticPlotLog Property (ActiveX)

Specifies whether to automatically save a Plot or Publish log.

Supported platforms: Windows only

Signature

VBA:

object.AutomaticPlotLog
object

Type: PreferencesOutput

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Controls if a log file is automatically created when plotting or publishing.

Remarks

This property is equivalent to the AutoCAD Options dialog box setting "Automatically Save Plot and Publish Log."

Examples

VBA:

Sub Example_AutomaticPlotLog()
    ' This example sets the AutoCAD Options dialog box
    ' setting Automatically Save Plot and Publish Log to True.

    Dim MyPreference As AcadPreferencesOutput
    Set MyPreference = AcadApplication.preferences.Output
    MyPreference.AutomaticPlotLog = True

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AutomaticPlotLog()
    ;; This example sets the AutoCAD Options dialog box
    ;; setting Automatically Save Plot and Publish Log to True.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))

    (vla-put-AutomaticPlotLog (vla-get-Output preferences) :vlax-true)
)