AutoSnapMarkerColor Property (ActiveX)

Specifies the color of the AutoSnap marker.

Supported platforms: Windows only

Signature

VBA:

object.AutoSnapMarkerColor
object

Type: PreferencesDrafting

The object this property applies to.

Property Value

Read-only: No

Type: acColor enum

Remarks

The initial value for this property is acYellow.

Examples

VBA:

Sub Example_AutoSnapMarkerColor()
    ' This example reads and modifies the preference value that controls
    ' the color of the AutoSnap marker. When finished, this example resets
    ' the preference value back to its original value.
    
    Dim ACADPref As AcadPreferencesDrafting
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the drafting preferences object
    Set ACADPref = ThisDrawing.Application.preferences.Drafting
    
    ' Read and display the original value
    originalValue = ACADPref.AutoSnapMarkerColor
    MsgBox "The AutoSnapMarkerColor preference is: " & originalValue

    ' Modify the AutoSnapMarkerColor preference by setting it to red
    ACADPref.AutoSnapMarkerColor = acRed
    newValue = ACADPref.AutoSnapMarkerColor
    MsgBox "The AutoSnapMarkerColor preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.AutoSnapMarkerColor = originalValue
    MsgBox "The AutoSnapMarkerColor preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AutoSnapMarkerColor()
    ;; This example reads and modifies the preference value that controls
    ;; the color of the AutoSnap marker. When finished, this example resets
    ;; the preference value back to its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
  
    ;; Get the drafting preferences object
    (setq ACADPref (vla-get-Drafting preferences))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-AutoSnapMarkerColor ACADPref))
    (alert (strcat "The AutoSnapMarkerColor preference is: " (itoa originalValue)))

    ;; Modify the AutoSnapMarkerColor preference by setting it to red
    (vla-put-AutoSnapMarkerColor ACADPref acRed)
    (setq newValue (vla-get-AutoSnapMarkerColor ACADPref))
    (alert (strcat "The AutoSnapMarkerColor preference has been set to: " (itoa newValue)))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-AutoSnapMarkerColor ACADPref originalValue) 
    (alert (strcat "The AutoSnapMarkerColor preference was reset back to: " (itoa originalValue)))
)