HyperlinkDisplayCursor Property (ActiveX)

Toggles the display of the hyperlink cursor and shortcut menu.

Supported platforms: Windows only

Signature

VBA:

object.HyperlinkDisplayCursor
object

Type: PreferencesUser

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

The initial value for this property is True.

When this property is enabled, the user sees a small bitmap (just below and to the right of the crosshairs) whenever the cursor is over an object that contains a hyperlink. When the property is disabled, this bitmap will not be shown.

Examples

VBA:

Sub Example_HyperlinkDisplayCursor()
    ' This example reads and modifies the preference value that controls
    ' the display of the hyperlink cursor and shortcut menu.
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadPreferencesUser
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the user preferences object
    Set ACADPref = ThisDrawing.Application.preferences.User
    
    ' Read and display the original value
    originalValue = ACADPref.HyperlinkDisplayCursor
    MsgBox "The HyperlinkDisplayCursor preference is set to: " & originalValue

    ' Modify the HyperlinkDisplayCursor preference by toggling the value
    ACADPref.HyperlinkDisplayCursor = Not (ACADPref.HyperlinkDisplayCursor)
    newValue = ACADPref.HyperlinkDisplayCursor
    MsgBox "The HyperlinkDisplayCursor preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.HyperlinkDisplayCursor = originalValue
    MsgBox "The HyperlinkDisplayCursor preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_HyperlinkDisplayCursor()
    ;; This example reads and modifies the preference value that controls
    ;; the display of the hyperlink cursor and shortcut menu.
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-HyperlinkDisplayCursor (vla-get-User preferences)))
    (alert (strcat "The HyperlinkDisplayCursor preference is set to: " (if (= originalValue :vlax-true) "True"  "False")))

    ;; Modify the HyperlinkDisplayCursor preference by toggling the value
    (vla-put-HyperlinkDisplayCursor (vla-get-User preferences) (if (= originalValue :vlax-true) :vlax-false :vlax-true))
    (setq newValue (vla-get-HyperlinkDisplayCursor (vla-get-User preferences)))
    (alert (strcat "The HyperlinkDisplayCursor preference has been set to: " (if (= newValue :vlax-true) "True"  "False")))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-HyperlinkDisplayCursor (vla-get-User preferences) originalValue)
    (alert (strcat "The HyperlinkDisplayCursor preference was reset back to: " (if (= originalValue :vlax-true) "True"  "False")))
)