AddEllipticalCone Method (ActiveX)

Creates a 3D solid elliptical cone on the XY plane of the WCS given the Center, MajorRadius, MinorRadius, and Height.

Supported platforms: Windows only

Signature

VBA:

RetVal = object.AddEllipticalCone(Center, MajorRadius, MinorRadius, Height)
object

Type: Block, ModelSpace, PaperSpace

The objects this method applies to.

Center

Access: Input-only

Type: Variant (three-element array of doubles)

The 3D WCS coordinates specifying the center of the bounding box.

MajorRadius

Access: Input-only

Type: Double

The length of the major radius for the ellipse base. Must be a positive number.

MinorRadius

Access: Input-only

Type: Double

The length of the minor radius for the ellipse base. Must be a positive number.

Height

Access: Input-only

Type: Double

The height of the cone. Must be a positive number.

Return Value (RetVal)

Type: 3DSolid

A 3DSolid object as the newly created elliptical cone.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_AddEllipticalCone()
    ' This example creates an elliptical cone in model space.
    
    Dim coneObj As Acad3DSolid
    Dim center(0 To 2) As Double
    Dim majorRadius As Double
    Dim minorRadius As Double
    Dim height As Double
    
    ' Define the elliptical cone
    center(0) = 0#: center(1) = 0#: center(2) = 0#
    majorRadius = 10#
    minorRadius = 5#
    height = 20#
    
    ' Create the elliptical cone in model space
    Set coneObj = ThisDrawing.ModelSpace.AddEllipticalCone(center, majorRadius, minorRadius, height)
    
    ' Change the viewing direction of the viewport to better see the cone
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    ZoomAll
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AddEllipticalCone()
    ;; This example creates an elliptical cone in model space.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
       
    ;; Define the elliptical cone
    (setq center (vlax-3d-point 0 0 0)
          majorRadius 10
	         minorRadius 5
	         height 20)
    
    ;; Create the elliptical cone in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq coneObj (vla-AddEllipticalCone modelSpace center majorRadius minorRadius height))

    ;; Change the viewing direction of the viewport to better see the cone
    (setq NewDirection (vlax-3d-point -1 -1 1))
    (setq activeViewport (vla-get-ActiveViewport doc))
    (vla-put-Direction activeViewport NewDirection)
    (vla-put-ActiveViewport doc activeViewport)
    (vla-ZoomAll acadObj)
)