Controls the assignment of grips within blocks.
Supported platforms: Windows only
VBA:
object.DisplayGripsWithinBlocks
Type: PreferencesSelection
The object this property applies to.
Read-only: No
Type: Boolean
The initial value of this property is False.
VBA:
Sub Example_DisplayGripsWithinBlocks() ' This example reads and modifies the preference value that controls ' the assignment of grips within blocks. ' When finished, this example resets the preference value back to ' its original value. Dim ACADPref As AcadPreferencesSelection Dim originalValue As Variant, newValue As Variant ' Get the selection preferences object Set ACADPref = ThisDrawing.Application.Preferences.Selection ' Read and display the original value originalValue = ACADPref.DisplayGripsWithinBlocks MsgBox "The DisplayGripsWithinBlocks preference is set to: " & originalValue ' Modify the DisplayGripsWithinBlocks preference by toggling the value ACADPref.DisplayGripsWithinBlocks = Not (originalValue) newValue = ACADPref.DisplayGripsWithinBlocks MsgBox "The DisplayGripsWithinBlocks preference has been set to: " & newValue ' Reset the preference back to its original value ' ' * Note: Comment out this last section to leave the change to ' this preference in effect ACADPref.DisplayGripsWithinBlocks = originalValue MsgBox "The DisplayGripsWithinBlocks preference was reset back to: " & originalValue End Sub
Visual LISP:
(vl-load-com) (defun c:Example_DisplayGripsWithinBlocks() ;; This example reads and modifies the preference value that controls ;; the assignment of grips within blocks. ;; When finished, this example resets the preference value back to ;; its original value. (setq acadObj (vlax-get-acad-object)) (setq preferences (vla-get-Preferences acadObj)) ;; Get the selection preferences object (setq ACADPref (vla-get-Selection preferences)) ;; Read and display the original value (setq originalValue (vla-get-DisplayGripsWithinBlocks ACADPref)) (alert (strcat "The DisplayGripsWithinBlocks preference is set to: " (if (= originalValue :vlax-true) "True" "False"))) ;; Modify the DisplayGripsWithinBlocks preference by toggling the value (vla-put-DisplayGripsWithinBlocks ACADPref (if (= originalValue :vlax-true) :vlax-false :vlax-true)) (setq newValue (vla-get-DisplayGripsWithinBlocks ACADPref)) (alert (strcat "The DisplayGripsWithinBlocks preference has been set to: " (if (= newValue :vlax-true) "True" "False"))) ;; Reset the preference back to its original value ;; ;; * Note: Comment out this last section to leave the change to ;; this preference in effect (vla-put-DisplayGripsWithinBlocks ACADPref originalValue) (alert (strcat "The DisplayGripsWithinBlocks preference was reset back to: " (if (= originalValue :vlax-true) "True" "False"))) )