DisplaySilhouette Property (ActiveX)

Controls whether silhouette curves of solid objects are displayed in Wireframe mode.

Supported platforms: Windows only

Signature

VBA:

object.DisplaySilhouette
object

Type: DatabasePreferences

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

The initial value for this property is False.

Note: The value of this property is stored in the DISPSILH system variable.

Examples

VBA:

Sub Example_DisplaySilhouette()
    ' This example returns the current setting of
    ' DisplaySilhouette. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim currDisplaySilhouette As Boolean
    
    ' Retrieve the current DisplaySilhouette value
    currDisplaySilhouette = ThisDrawing.Preferences.DisplaySilhouette
    MsgBox "The current value for DisplaySilhouette is " & preferences.DisplaySilhouette, vbInformation, "DisplaySilhouette Example"
    
    ' Change the value for DisplaySilhouette
    ThisDrawing.Preferences.DisplaySilhouette = Not (currDisplaySilhouette)
    MsgBox "The new value for DisplaySilhouette is " & preferences.DisplaySilhouette, vbInformation, "DisplaySilhouette Example"
    
    ' Reset DisplaySilhouette to its original value
    ThisDrawing.Preferences.DisplaySilhouette = currDisplaySilhouette
    MsgBox "The DisplaySilhouette value is reset to " & preferences.DisplaySilhouette, vbInformation, "DisplaySilhouette Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_DisplaySilhouette()
    ;; This example returns the current setting of
    ;; DisplaySilhouette. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    (setq preferences (vla-get-Preferences doc))
    
    ;; Retrieve the current DisplaySilhouette value
    (setq currDisplaySilhouette (vla-get-DisplaySilhouette preferences))
    (alert (strcat "The current value for DisplaySilhouette is " (if (= currDisplaySilhouette :vlax-true) "True" "False")))
    
    ;; Change the value for DisplaySilhouette
    (setq newValue (if (= currDisplaySilhouette :vlax-true) :vlax-false :vlax-true))
    (vla-put-DisplaySilhouette preferences newValue)
    (alert (strcat "The new value for DisplaySilhouette is " (if (= newValue :vlax-true) "True" "False")))
    
    ;; Reset DisplaySilhouette to its original value
    (vla-put-DisplaySilhouette preferences currDisplaySilhouette)
    (alert (strcat "The DisplaySilhouette value is reset to " (if (= currDisplaySilhouette :vlax-true) "True" "False")))
)