Circumference Property (ActiveX)

Specifies the circumference of a circle.

Supported platforms: Windows only

Signature

VBA:

object.Circumference
object

Type: Circle

The object this property applies to.

Property Value

Read-only: No

Type: Double

The circumference of the circle.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_Circumference()
    ' This example creates a Circle object in model space and
    ' returns the circumference of the Circle
    
    Dim circleObj As AcadCircle
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    
    ' Define the new Circle object
    centerPoint(0) = 0: centerPoint(1) = 0: centerPoint(2) = 0
    radius = 5#
    
    ' Create the Circle object in model space
    Set circleObj = ThisDrawing.ModelSpace.AddCircle(centerPoint, radius)

    ThisDrawing.Application.ZoomAll
    
    MsgBox "The circumference of the new Circle is: " & circleObj.Circumference
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Circumference()
    ;; This example creates a Circle object in model space and
    ;; returns the circumference of the Circle
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))   
    
    ;; Define the new Circle object
    (setq centerPoint (vlax-3d-point 5 5 0)
          radius 5)
    
    ;; Create the Circle object in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq circleObj (vla-AddCircle modelSpace centerPoint radius))

    (vla-ZoomAll acadObj)
    
    (alert (strcat "The circumference of the new Circle is: " (rtos (vla-get-Circumference circleObj) 2)))
)