OpenSave Property (ActiveX)

Gets the PreferencesOpenSave object.

Supported platforms: Windows only

Signature

VBA:

object.OpenSave
object

Type: Preferences

The object this property applies to.

Property Value

Read-only: Yes

Type: PreferencesOpenSave

Gets the PreferencesOpenSave object.

Remarks

The PreferencesOpenSave object holds all the options from the Open and Save tab on the Options dialog stored in the registry. All options that are stored with the drawing can be found on the DatabasePreferences object.

Examples

VBA:

Sub Example_OpenSave()
    ' This example obtains a reference to the OpenSave Preferences object
    ' from the Application Preferences object, and reads one of the OpenSave
    ' preferences
    
    Dim ACADPref As AcadPreferencesOpenSave
    
    ' Obtain a reference to the OpenSave Preferences object
    Set ACADPref = ThisDrawing.Application.preferences.OpenSave
    
    MsgBox "You now have access to the properties and methods of the OpenSave Preferences object!"
    MsgBox "The OpenSave preference TempFileExtension is set to: " & ACADPref.TempFileExtension

End Sub

Visual LISP:

Not available