SCMTimeMode Property (ActiveX)

Controls time-sensitive right-click behavior.

Supported platforms: Windows only

Signature

VBA:

object.SCMTimeMode
object

Type: PreferencesUser

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

This property is for setting time-sensitive right-click behavior. A quick click is the same as pressing Enter. A longer click displays a shortcut menu. This property can only be set when the ShortcutMenuDisplay property is set to True.

You can set a duration for the right-click using the SCMTimeValue property.

Note: The value of this property is stored in the SHORTCUTMENUDURATION system variable.

Examples

VBA:

Sub Example_SCMTimeMode()
    ' This example reads and modifies the SCMTimeMode property.
    ' Then the property is reset to its original value.
    
    Dim ACADPref As AcadPreferencesUser
    Dim originalValue As Boolean, newValue As Boolean
    
    ' Get the UserPreferences object
    Set ACADPref = ThisDrawing.Application.Preferences.User
    
    originalValue = ACADPref.SCMTimeMode
    MsgBox "The SCMTimeMode property is currently: " & originalValue
    
    newValue = IIf(originalValue, False, True)
    ACADPref.SCMTimeMode = newValue
    
    MsgBox "The SCMTimeMode property has been set to: " & ACADPref.SCMTimeMode

    ' Reset the preference back to its original value
    ACADPref.SCMTimeMode = originalValue
    MsgBox "The SCMTimeMode property was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_SCMTimeMode()
    ;; This example reads and modifies the SCMTimeMode property.
    ;; Then the property is reset to its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-SCMTimeMode (vla-get-User preferences)))
    (alert (strcat "The SCMTimeMode property is currently: " (if (= originalValue :vlax-true) "True" "False")))
  
    ;; Modify the SCMTimeMode preference by toggling the value
    (setq newValue (if (= originalValue :vlax-true) :vlax-false :vlax-true))
    (vla-put-SCMTimeMode (vla-get-User preferences) newValue)
    (alert (strcat "The SCMTimeMode property has been set to: " (if (= newValue :vlax-true) "True" "False")))

    ;; Reset the preference back to its original value
    (vla-put-SCMTimeMode (vla-get-User preferences) originalValue)
    (alert (strcat "The SCMTimeMode property was reset back to: " (if (= originalValue :vlax-true) "True" "False")))
)