Gets the principal directions of the solid or region.
Supported platforms: Windows only
VBA:
object.PrincipalDirections
Read-only: Yes
Type: Variant (three-element array of doubles)
The X, Y, and Z coordinates calculated on the current coordinate system.
The principal directions are returned as X, Y, and Z coordinates defined as a variant. They are calculated based on the current coordinate system.
VBA:
Sub Example_PrincipalDirections() ' This example creates a box in model space. ' It then returns the PrincipalDirections for that box. Dim boxObj As Acad3DSolid Dim length As Double, width As Double, height As Double Dim center(0 To 2) As Double ' Define the box center(0) = 5#: center(1) = 5#: center(2) = 0 length = 5#: width = 7: height = 10# ' Create the box (3DSolid) object in model space Set boxObj = ThisDrawing.ModelSpace.AddBox(center, length, width, height) ' Change the viewing direction of the viewport to better see the box Dim NewDirection(0 To 2) As Double NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1 ThisDrawing.ActiveViewport.direction = NewDirection ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport ZoomAll ' Return the PrincipalDirections for the box Dim PrincipalDirections As Variant PrincipalDirections = boxObj.PrincipalDirections MsgBox "The PrincipalDirections for the box are " & PrincipalDirections(0) & ", " & PrincipalDirections(1) & ", " & PrincipalDirections(2), , "PrincipalDirections Example" End Sub
Visual LISP:
(vl-load-com) (defun c:Example_PrincipalDirections() ;; This example creates a box in model space. ;; It then returns the PrincipalDirections for that box. (setq acadObj (vlax-get-acad-object)) (setq doc (vla-get-ActiveDocument acadObj)) ;; Define the box (setq center (vlax-3d-point 5 5 0) boxLength 5 boxWidth 7 boxHeight 10) ;; Create the box (3DSolid) object in model space (setq modelSpace (vla-get-ModelSpace doc)) (setq boxObj (vla-AddBox modelSpace center boxLength boxWidth boxHeight)) ;; Change the viewing direction of the viewport to better see the box (setq NewDirection (vlax-3d-point -1 -1 1)) (setq activeViewport (vla-get-ActiveViewport doc)) (vla-put-Direction activeViewport NewDirection) (vla-put-ActiveViewport doc activeViewport) (vla-ZoomAll acadObj) ;; Return the PrincipalDirections for the box (setq PrincipalDirections (vlax-variant-value (vla-get-PrincipalDirections boxObj))) (alert (strcat "The PrincipalDirections for the box are " (rtos (vlax-safearray-get-element PrincipalDirections 0) 2) ", " (rtos (vlax-safearray-get-element PrincipalDirections 1) 2) ", " (rtos (vlax-safearray-get-element PrincipalDirections 2) 2))) )