ArcSmoothness Property (ActiveX)

Specifies the smoothness of circles, arcs, and ellipses.

Supported platforms: Windows only

Signature

VBA:

object.ArcSmoothness
object

Type: PViewport, Viewport

The objects this property applies to.

Property Value

Read-only: No

Type: Integer

A positive integer from 1 to 20,000.

Remarks

The initial value for this property is 100.

A higher number produces smoother objects, but AutoCAD requires more time to regenerate them. You can improve performance by setting this property to a low value for drawing and increasing the value for rendering. The valid range is 1 through 20,000.

Examples

VBA:

Sub Example_ArcSmoothness()
    ' This example returns the current setting of
    ' ArcSmoothness. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim currArcSmoothness As Integer
    Dim newArcSmoothness As Integer
        
    ' Retrieve the current ArcSmoothness value
    currArcSmoothness = ThisDrawing.ActiveViewport.ArcSmoothness
    MsgBox "The current value for ArcSmoothness is " & currArcSmoothness, vbInformation, "ArcSmoothness Example"
    
    ' Change the value for ArcSmoothness
    newArcSmoothness = 2001
    ThisDrawing.ActiveViewport.ArcSmoothness = newArcSmoothness
    MsgBox "The new value for ArcSmoothness is " & newArcSmoothness, vbInformation, "ArcSmoothness Example"
    
    ' Reset ArcSmoothness to its original value
    ThisDrawing.ActiveViewport.ArcSmoothness = currArcSmoothness
    MsgBox "The ArcSmoothness value is reset to " & currArcSmoothness, vbInformation, "ArcSmoothness Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ArcSmoothness()
    ;; This example returns the current setting of
    ;; ArcSmoothness. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    ;; Retrieve the current ArcSmoothness value
    (setq currArcSmoothness (vla-get-ArcSmoothness (vla-get-ActiveViewport doc)))
    (alert (strcat "The current value for ArcSmoothness is " (itoa currArcSmoothness)))
    
    ;; Change the value for ArcSmoothness
    (setq newArcSmoothness 2001)
    (vla-put-ArcSmoothness (vla-get-ActiveViewport doc) newArcSmoothness)
    (alert (strcat "The new value for ArcSmoothness is " (itoa newArcSmoothness)))
    
    ;; Reset ArcSmoothness to its original value
    (vla-put-ArcSmoothness (vla-get-ActiveViewport doc) currArcSmoothness)
    (alert (strcat "The ArcSmoothness value is reset to " (itoa currArcSmoothness)))
)