ExportProfile Method (ActiveX)

Exports the active profile so it can be shared with other users.

Supported platforms: Windows only

Signature

VBA:

object.ExportProfile Profile, RegFile
object

Type: PreferencesProfiles

The object this method applies to.

Profile

Access: Input-only

Type: String

The name of the profile to be exported.

RegFile

Access: Input-only

Type: String

The name of the file the profile will be exported to. The extension of the file should be .arg.

Return Value (RetVal)

No return value.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_ExportProfile()
    ' This example exports the active profile to a new name.
    
    Dim preferences As AcadPreferences
    Dim currActiveProfile As String
    
    Set preferences = ThisDrawing.Application.preferences
    
    ' Retrieve the current ActiveProfile value
    currActiveProfile = preferences.Profiles.ActiveProfile
    MsgBox "The current ActiveProfile is: " & preferences.Profiles.ActiveProfile, , "ExportProfile Example"
    
    ' Export the active profile
    preferences.Profiles.ExportProfile currActiveProfile, "TestProfile.arg"
    MsgBox "The ActiveProfile has been exported to: TestProfile.arg", , "ExportProfile Example"
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ExportProfile()
    ;; This example exports the active profile to a new name.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
  
    ;; Retrieve the current ActiveProfile value
    (setq currActiveProfile (vla-get-ActiveProfile (vla-get-Profiles preferences)))
    (alert (strcat "The current ActiveProfile is: " currActiveProfile))
    
    ;; Export the active profile
    (vla-ExportProfile (vla-get-Profiles preferences) currActiveProfile "c:\\Temp\\TestProfile.arg")
    (alert "The ActiveProfile has been exported to: TestProfile.arg")
)