Fade Property (ActiveX)

Specifies the current fade value of a raster or underlay image.

Supported platforms: Windows only

Signature

VBA:

object.Fade
object

Type: DgnUnderlay, DwfUnderlay, GeomapImage, PdfUnderlay, RasterImage, Wipeout

The objects this property applies to.

Property Value

Read-only: No

Type: Long

The value is between 0 and 100 inclusive.

Remarks

You can adjust the raster or underlay image brightness, contrast, and fade to the display of the image as well as to the plotted output without affecting the original raster or underlay file. Adjust brightness to darken or lighten an image. Adjust contrast to make images with poor quality easier to read. Adjust fade to make vectors easier to see over images and to create a watermark effect in your plotted output.

Note: Bitonal images cannot be adjusted for brightness, contrast, or fade.

Examples

VBA:

Sub Example_Fade()
    ' This example inserts a raster image and finds the current
    ' Fade value of the image. It then changes the Fade value
    ' of the image.
    
    ' This example uses the "2d Projected Polylines.jpg" found in the Sample
    ' directory. If you do not have the image, or if it is located
    ' in a different directory, insert a valid path and name for the
    ' imageName variable below.
    Dim insertionPoint(0 To 2) As Double
    Dim scalefactor As Double
    Dim rotAngleInDegree As Double
    Dim rotAngle As Double
    Dim imageName As String
    Dim raster As AcadRasterImage
    imageName = "C:\AutoCAD\sample\2d Projected Polylines.jpg"
    insertionPoint(0) = 2#: insertionPoint(1) = 2#: insertionPoint(2) = 0#
    scalefactor = 1#
    rotAngleInDegree = 0#
    rotAngle = rotAngleInDegree * 3.141592 / 180#
    
    On Error Resume Next
    
    ' Creates a raster image in model space
    Set raster = ThisDrawing.ModelSpace.AddRaster(imageName, insertionPoint, scalefactor, rotAngle)
    If Err.Description = "Filer error" Then
        MsgBox imageName & " could not be found."
        Exit Sub
    End If

    ' Find the current Fade
    ThisDrawing.Regen True
    MsgBox "The Fade is currently set to: " & raster.Fade, vbInformation
    
    ' Change the Fade to 5
    raster.Fade = 50
    ThisDrawing.Regen True
    MsgBox "The Fade is now set to: " & raster.Fade, vbInformation
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Fade()
    ;; This example inserts a raster image and finds the current
    ;; Fade value of the image. It then changes the Fade value
    ;; of the image.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    ;; This example uses the "2d Projected Polylines.jpg" found in the Sample
    ;; directory. If you do not have the image, or if it is located
    ;; in a different directory, insert a valid path and name for the
    ;; imageName variable below.
    (setq insertionPoint (vlax-3d-point 2 2 0)
          imageName ".\\Sample\\VBA\\2d Projected Polylines.jpg"
          scalefactor 1
          rotAngle (/ (* 0 3.141592) 180))

    (if (/= (findfile imageName) nil)
        (progn
            ;; Creates a raster image in model space
            (setq modelSpace (vla-get-ModelSpace doc))
            (setq raster (vla-AddRaster modelSpace (findfile imageName) insertionPoint scalefactor rotAngle))
            (vla-ZoomExtents acadObj)

            ;; Find the current Fade
            (vla-Regen doc :vlax-true)
            (alert (strcat "The Fade is currently set to: " (rtos (vla-get-Fade raster) 2)))
    
            ;; Change the Fade to 5
            (vla-put-Fade raster 5)
            (vla-Regen doc :vlax-true)
            (alert (strcat "The Fade is now set to: " (rtos (vla-get-Fade raster) 2)))	  
	)
        (alert (strcat imageName " could not be found."))
    )
)