QuietErrorMode Property (ActiveX)

Toggles the quiet error mode for plot-error reporting.

Supported platforms: Windows only

Signature

VBA:

object.QuietErrorMode
object

Type: Plot

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

Quiet error mode logs all plot-related error messages into a log file.

When the quiet error mode is disabled, the normal error reporting mechanisms (alert boxes) are used.

Examples

VBA:

Sub Example_QuietErrorMode()
    ' This example plots the layouts of a drawing.

    Dim oPlot As AcadPlot
    Dim AddedLayouts() As String
    Dim LayoutList As Variant
    Dim oLayout As ACADLayout
    Dim ArraySize As Integer, BatchCount As Integer
    
    For Each oLayout In ThisDrawing.Layouts
        ArraySize = ArraySize + 1
        ReDim Preserve AddedLayouts(1 To ArraySize)
        AddedLayouts(ArraySize) = oLayout.Name
    Next

    LayoutList = AddedLayouts
    Set oPlot = ThisDrawing.Plot
    oPlot.SetLayoutsToPlot LayoutList
    oPlot.PlotToDevice "DWF6 ePlot.pc3"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_QuietErrorMode()
    ;; This example plots the layouts of a drawing.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    (setq AddedLayouts (vlax-make-safearray vlax-vbString (cons 0 (1- (vla-get-Count (vla-get-Layouts doc)))))
          ArraySize 0)
    
    (vlax-for oLayout (vla-get-Layouts doc)
        (vlax-safearray-put-element AddedLayouts ArraySize (vla-get-Name oLayout))
        (setq ArraySize (1+ ArraySize))
    )

    (setq oPlot (vla-get-Plot doc))
    (setq currMode (vla-get-QuietErrorMode oPlot))
    (vla-put-QuietErrorMode oPlot :vlax-true)
    (vla-SetLayoutsToPlot oPlot AddedLayouts)
    (vla-PlotToDevice oPlot "DWF6 ePlot.pc3")
    (vla-put-QuietErrorMode oPlot currMode)
)