FieldLength Property (ActiveX)

Specifies the field length of the attribute.

Supported platforms: Windows only

Signature

VBA:

object.FieldLength
object

Type: Attribute, AttributeReference

The objects this property applies to.

Property Value

Read-only: No

Type: Integer

The field length of the attribute.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_FieldLength()
    ' This example creates an attribute definition in model space.
    ' It then queries the initial value of the FieldLength property,
    ' changes that value, and finally resets the value.
    
    Dim attributeObj As AcadAttribute
    Dim height As Double
    Dim mode As Long
    Dim prompt As String
    Dim insertionPoint(0 To 2) As Double
    Dim tag As String
    Dim value As String
    
    ' Define the attribute definition
    height = 1#
    mode = acAttributeModeVerify
    prompt = "New Prompt"
    insertionPoint(0) = 5#: insertionPoint(1) = 5#: insertionPoint(2) = 0
    tag = "New_Tag"
    value = "New Value"
    
    ' Create the attribute definition object in model space
    Set attributeObj = ThisDrawing.ModelSpace.AddAttribute(height, mode, prompt, insertionPoint, tag, value)
    ZoomAll
    
    ' Return the current field length of the attribute
    Dim currFieldLength As Integer
    currFieldLength = attributeObj.FieldLength
    MsgBox "The FieldLength of the attribute is " & attributeObj.FieldLength, vbInformation, "FieldLength Example"
    
    ' Change the field length
    attributeObj.FieldLength = currFieldLength + 2
    attributeObj.Update
    MsgBox "The new FieldLength of the attribute is " & attributeObj.FieldLength, vbInformation, "FieldLength Example"
    
    ' Reset the field length to the original value
    attributeObj.FieldLength = currFieldLength
    attributeObj.Update
    MsgBox "The FieldLength of the attribute is reset to " & attributeObj.FieldLength, vbInformation, "FieldLength Example"
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_FieldLength()
    ;; This example creates an attribute definition in model space.
    ;; It then queries the initial value of the FieldLength property,
    ;; changes that value, and finally resets the value.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    ;; Define the attribute definition
    (setq insertionPoint (vlax-3d-point 5 5 0)
          height 1
          attMode acAttributeModeVerify
          attPrompt "New Prompt"
          attTag "NEW_TAG"
          attValue "New Value")
    
    ;; Create the attribute definition object in model space
    (setq modelSpace (vla-get-ModelSpace doc))  
    (setq attributeObj (vla-AddAttribute modelSpace height attMode attPrompt insertionPoint attTag attValue))
    (vla-ZoomAll acadObj)
    
    ;; Return the current field length of the attribute
    (setq currFieldLength (vla-get-FieldLength attributeObj))
    (alert (strcat "The FieldLength of the attribute is " (itoa currFieldLength)))
    
    ;; Change the field length
    (setq newFieldLength (+ currFieldLength 2))
    (vla-put-FieldLength attributeObj newFieldLength)
    (vla-Update attributeObj)
    (alert (strcat "The new FieldLength of the attribute is " (itoa newFieldLength)))
    
    ;; Reset the field length to the original value
    (vla-put-FieldLength attributeObj currFieldLength)
    (vla-Update attributeObj)
    (alert (strcat "The FieldLength of the attribute is reset to " (itoa currFieldLength)))
)