PickfirstSelectionSet Property (ActiveX)

Gets the pickfirst selection set.

Supported platforms: Windows only

Signature

VBA:

object.PickfirstSelectionSet
object

Type: Document

The object this property applies to.

Property Value

Read-only: Yes

Type: SelectionSet

The pickfirst selection set.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_PickfirstSelectionSet()
    ' This example lists all the objects in the pickfirst selection set.
    ' Before running this example, create some objects in the active
    ' drawing and select those objects. The objects currently selected
    ' in the active drawing will be returned in the pickfirst selection set.
            
    Dim pfSS As AcadSelectionSet
    Dim ssobject As AcadEntity
    Dim msg As String
    msg = ""
    
    Set pfSS = ThisDrawing.PickfirstSelectionSet
    For Each ssobject In pfSS
        msg = msg & vbCrLf & ssobject.ObjectName
    Next ssobject
    MsgBox "The Pickfirst selection set contains: " & msg
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_PickfirstSelectionSet()
    ;; This example lists all the objects in the pickfirst selection set.
    ;; Before running this example, create some objects in the active
    ;; drawing and select those objects. The objects currently selected
    ;; in the active drawing will be returned in the pickfirst selection set.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
            
    (setq msg ""
          pfSS (vla-get-PickfirstSelectionSet doc))
  
    (vlax-for ssobject pfSS
        (setq msg (strcat msg "\n" (vla-get-ObjectName ssobject)))
    )

    (alert (strcat "The Pickfirst selection set contains: " msg))
)