TextFontSize Property (ActiveX)

Specifies the font size for new text.

Supported platforms: Windows only

Signature

VBA:

object.TextFontSize
object

Type: PreferencesDisplay

The object this property applies to.

Property Value

Read-only: No

Type: Integer

The font size for new text. The limit for the font size is determined by the font.

Remarks

The initial value for this property is 10.

Examples

VBA:

Sub Example_TextFontSize()
    ' This example returns the current setting of
    ' TextFontSize. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim preferences As AcadPreferences
    Dim currTextFontSize As Integer
    
    Set preferences = ThisDrawing.Application.Preferences
    
    ' Retrieve the current TextFontSize value
    currTextFontSize = preferences.Display.TextFontSize
    MsgBox "The current value for TextFontSize is " & preferences.Display.TextFontSize, vbInformation, "TextFontSize Example"
    
    ' Change the value for TextFontSize
    preferences.Display.TextFontSize = 12
    MsgBox "The new value for TextFontSize is " & preferences.Display.TextFontSize, vbInformation, "TextFontSize Example"
    
    ' Reset TextFontSize to its original value
    preferences.Display.TextFontSize = currTextFontSize
    MsgBox "The TextFontSize value is reset to " & preferences.Display.TextFontSize, vbInformation, "TextFontSize Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_TextFontSize()
    ;; This example returns the current setting of
    ;; TextFontSize. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Retrieve the current TextFontSize value
    (setq currTextFontSize (vla-get-TextFontSize (vla-get-Display preferences)))
    (alert (strcat "The current value for TextFontSize is " (itoa currTextFontSize)))
    
    ;; Change the value for TextFontSize
    (vla-put-TextFontSize (vla-get-Display preferences) 12)
    (alert (strcat "The new value for TextFontSize is " (itoa (vla-get-TextFontSize (vla-get-Display preferences)))))
    
    ;; Reset TextFontSize to its original value
    (vla-put-TextFontSize (vla-get-Display preferences) currTextFontSize)
    (alert (strcat "The TextFontSize value is reset to " (itoa (vla-get-TextFontSize (vla-get-Display preferences)))))
)