GripSize Property (ActiveX)

Specifies the size of grips.

Supported platforms: Windows only

Signature

VBA:

object.GripSize
object

Type: PreferencesSelection

The object this property applies to.

Property Value

Read-only: No

Type: Longt

The size of the box drawn to display the grip, in pixels. The practical range for this property is 1 to 20, although any value from 1 to 255 is valid.

Remarks

The initial value of this property is 3.

Note: The value for this property is stored in the GRIPSIZE system variable.

Examples

VBA:

Sub Example_GripSize()
    ' This example reads and modifies the preference value that controls
    ' the size of grips. When finished, this example resets the
    ' preference value back to its original value.
    
    Dim ACADPref As AcadPreferencesSelection
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the selection preferences object
    Set ACADPref = ThisDrawing.Application.preferences.Selection
    
    ' Read and display the original value
    originalValue = ACADPref.GripSize
    MsgBox "The GripSize preference is set to: " & originalValue

    ' Modify the GripSize preference by setting it to 5
    ACADPref.GripSize = 5
    newValue = ACADPref.GripSize
    MsgBox "The GripSize preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.GripSize = originalValue
    MsgBox "The GripSize preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_GripSize()
    ;; This example reads and modifies the preference value that controls
    ;; the size of grips. When finished, this example resets the
    ;; preference value back to its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Get the selection preferences object
    (setq ACADPref (vla-get-Selection (vla-get-preferences acadObj)))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-GripSize ACADPref))
    (alert (strcat "The GripSize preference is set to: " (itoa originalValue)))

    ;; Modify the GripSize preference by setting it to 7
    (vla-put-GripSize ACADPref 7)
    (setq newValue (vla-get-GripSize ACADPref))
    (alert (strcat "The GripSize preference has been set to: " (itoa newValue)))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-GripSize ACADPref originalValue)
    (alert (strcat "The GripSize preference was reset back to: " (itoa originalValue)))
)