TextWinBackgrndColor Property (ActiveX)

Specifies the background color for the text window.

Supported platforms: Windows only

Signature

VBA:

object.TextWinBackgrndColor
object

Type: PreferencesDisplay

The object this property applies to.

Property Value

Read-only: No

Type: OLE_COLOR (constant)

Remarks

The default color for this property is the Windows standard window color.

Examples

VBA:

Sub Example_TextWinBackgrndColor()
    ' This example returns the current setting of
    ' TextWinBackgrndColor. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim preferences As AcadPreferences
    Dim currTextWinBackgrndColor As OLE_COLOR
    
    Set preferences = ThisDrawing.Application.Preferences
    
    ' Retrieve the current TextWinBackgrndColor value
    currTextWinBackgrndColor = preferences.Display.TextWinBackgrndColor
    MsgBox "The current value for TextWinBackgrndColor is " _
           & preferences.Display.TextWinBackgrndColor, vbInformation, "TextWinBackgrndColor Example"
    
    ' Change the value for TextWinBackgrndColor
    preferences.Display.TextWinBackgrndColor = vbBlue
    MsgBox "The new value for TextWinBackgrndColor is " _
           & preferences.Display.TextWinBackgrndColor, vbInformation, "TextWinBackgrndColor Example"
    
    ' Reset TextWinBackgrndColor to its original value
    preferences.Display.TextWinBackgrndColor = currTextWinBackgrndColor
    MsgBox "The TextWinBackgrndColor value is reset to " _
           & preferences.Display.TextWinBackgrndColor, vbInformation, "TextWinBackgrndColor Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_TextWinBackgrndColor()
    ;; This example returns the current setting of
    ;; TextWinBackgrndColor. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))

    ;; Get the Display preferences object
    (setq ACADPref (vla-get-Display preferences))

    ;; Retrieve the current TextWinBackgrndColor value
    (setq currTextWinBackgrndColor (vlax-variant-change-type (vla-get-TextWinBackgrndColor ACADPref) vlax-vbLong))
    (alert (strcat "The current value for TextWinBackgrndColor is " (itoa (vlax-variant-value currTextWinBackgrndColor))))
    
    ;; Change the value for TextWinBackgrndColor
    (vla-put-TextWinBackgrndColor ACADPref (vlax-make-variant acBlue 19))
    (setq newValue (vlax-variant-change-type (vla-get-TextWinBackgrndColor ACADPref) vlax-vbLong))
    (alert (strcat "The new value for TextWinBackgrndColor is " (itoa (vlax-variant-value newValue))))
    
    ;; Reset TextWinBackgrndColor to its original value
    (vla-put-TextWinBackgrndColor ACADPref (vlax-variant-change-type currTextWinBackgrndColor 19)) 
    (alert (strcat "The TextWinBackgrndColor value is reset to " (itoa (vlax-variant-value currTextWinBackgrndColor))))
)