Specifies the standard scale for the layout, viewport, or plot configuration.
Supported platforms: Windows only
VBA:
object.StandardScale
Type: Layout, PlotConfiguration, PViewport
The object this property applies to.
Read-only: No
Type: acPlotScale enum; Layout and PlotConfiguration objects, acViewportScale enum; PViewport objects
acPlotScale enum
acViewportScale enum
To set the viewport to a custom scale, set this property to acVpCustomScale and then use the CustomScale property to define the custom scale value.
Changes to this property will not be visible until after a regeneration of the drawing. Use the Regen method to regenerate the drawing.
VBA:
Sub Example_StandardScale() ' This example will access the active layout for the current drawing ' and list the standard scale for that Layout. ' It then changes the standard scale for the layout, and finally ' resets the scale back to its original value. Dim Layout As ACADLayout Dim currScale As Integer ' Get the activeLayout Set Layout = ThisDrawing.ActiveLayout ' Find the current standard scale currScale = Layout.StandardScale MsgBox "The current standard scale is : " & Layout.StandardScale ' Change the standard scale to 100:1 Layout.StandardScale = ac100_1 MsgBox "The new standard scale is : " & Layout.StandardScale ' Reset the original standard scale Layout.StandardScale = currScale MsgBox "The new standard scale is : " & Layout.StandardScale End Sub
Visual LISP:
(vl-load-com) (defun c:Example_StandardScale() ;; This example will access the active layout for the current drawing ;; and list the standard scale for that Layout. ;; It then changes the standard scale for the layout, and finally ;; resets the scale back to its original value. (setq acadObj (vlax-get-acad-object)) (setq doc (vla-get-ActiveDocument acadObj)) ;; Get the activeLayout (setq Layout (vla-get-ActiveLayout doc)) ;; Find the current standard scale (setq currScale (vla-get-StandardScale Layout)) (alert (strcat "The current standard scale is : " (itoa currScale))) ;; Change the standard scale to 100:1 (vla-put-StandardScale Layout ac100_1) (alert (strcat "The new standard scale is : " (itoa (vla-get-StandardScale Layout)))) ;; Reset the original standard scale (vla-put-StandardScale Layout currScale) (alert (strcat "The new standard scale is : " (itoa (vla-get-StandardScale Layout)))) )