DefaultPlotStyleForLayer Property (ActiveX)

Specifies the default plot style for Layer 0 for new drawings or drawings created with earlier releases of AutoCAD that have never been saved in AutoCAD 2000 or later format.

Supported platforms: Windows only

Signature

VBA:

object.DefaultPlotStyleForLayer
object

Type: PreferencesOutput

The object this property applies to.

Property Value

Read-only: No

Type: String

You can enter the default value "Normal" and enter any plot styles defined in the currently loaded plot style table.

Remarks

The initial value of this property is "Normal".

This property is only available when PlotPolicy is set to acPolicyNamed.

Use the DefaultPlotStyleTable property to find the current plot style.

Note: The value of this property is stored in the DEFLPLSTYLE system variable.

Examples

VBA:

Sub Example_DefaultPlotStyleForLayer()
    ' This example reads and modifies the preference value that controls
    ' the default plot style assigned to layers.
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadPreferencesOutput
    Dim originalPolicyValue As Variant, originalValue As Variant, _
        originalPlotStyleTableValue As Variant, newValue As Variant
    
    ' Get the output preferences object
    Set ACADPref = ThisDrawing.Application.preferences.Output
    
    ' Set the default plot style to named plot styles
    originalPolicyValue = ACADPref.PlotPolicy
    ACADPref.PlotPolicy = acPolicyNamed
    
    ' Read and display the original value
    originalValue = ACADPref.DefaultPlotStyleForLayer
    MsgBox "The DefaultPlotStyleForLayer preference is: " & originalValue

    originalPlotStyleTableValue = ACADPref.DefaultPlotStyleTable
    ACADPref.DefaultPlotStyleTable = "acad.stb"

    ' Toggle and display the DefaultPlotStyleForLayer preference
    If ACADPref.DefaultPlotStyleForLayer = "Style 1" Then
        ACADPref.DefaultPlotStyleForLayer = "Normal"
    Else
        ACADPref.DefaultPlotStyleForLayer = "Style 1"
    End If

    newValue = ACADPref.DefaultPlotStyleForLayer
    MsgBox "The DefaultPlotStyleForLayer preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.DefaultPlotStyleForLayer = originalValue
    MsgBox "The DefaultPlotStyleForLayer preference was reset back to: " & originalValue
    
    ' Restore the original plot style
    ACADPref.PlotPolicy = originalPolicyValue
    ACADPref.DefaultPlotStyleTable = originalPlotStyleTableValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_DefaultPlotStyleForLayer()
    ;; This example reads and modifies the preference value that controls
    ;; the default plot style assigned to layers.
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))

    ;; Get the output preferences object
    (setq ACADPref (vla-get-Output preferences))

    ;; Set the default plot style to named plot styles
    (setq originalPolicyValue (vla-get-PlotPolicy ACADPref))
    (vla-put-PlotPolicy ACADPref acPolicyNamed)

    (setq originalPlotStyleTableValue (vla-get-DefaultPlotStyleTable ACADPref))
    (vla-put-DefaultPlotStyleTable ACADPref "acad.stb")
  
    ;; Read and display the original value
    (setq originalValue (vla-get-DefaultPlotStyleForLayer ACADPref))
    (alert (strcat "The DefaultPlotStyleForLayer preference is: " originalValue))

    ;; Toggle and display the DefaultPlotStyleForLayer preference
    (if (= (vla-get-DefaultPlotStyleForLayer ACADPref) "Style 1")
        (vla-put-DefaultPlotStyleForLayer ACADPref "Normal")
        (vla-put-DefaultPlotStyleForLayer ACADPref "Style 1")
    )

    (setq newValue (vla-get-DefaultPlotStyleForLayer ACADPref))
    (alert (strcat "The DefaultPlotStyleForLayer preference has been set to: " newValue))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-DefaultPlotStyleForLayer ACADPref originalValue)
    (alert (strcat "The DefaultPlotStyleForLayer preference was reset back to: " originalValue))

    ;; Restore the original plot style
    (vla-put-PlotPolicy ACADPref originalPolicyValue)
    (vla-put-DefaultPlotStyleTable ACADPref originalPlotStyleTableValue)
)