TextEditor Property (ActiveX)

Specifies the name of the text editor for the MTEXT command.

Supported platforms: Windows only

Signature

VBA:

object.TextEditor
object

Type: PreferencesFiles

The object this property applies to.

Property Value

Read-only: No

Type: String

The name of the multiline text editor.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_TextEditor()
    ' This example returns the current setting of
    ' TextEditor. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim preferences As AcadPreferences
    Dim currTextEditor As String
    Dim newTextEditor As String
    
    Set preferences = ThisDrawing.Application.preferences
    
    ' Retrieve the current TextEditor value
    currTextEditor = preferences.Files.TextEditor
    MsgBox "The current value for TextEditor is " & currTextEditor, vbInformation, "TextEditor Example"
    
    ' Change the value for TextEditor
    newTextEditor = "TestTextEditor"
    preferences.Files.TextEditor = newTextEditor
    MsgBox "The new value for TextEditor is " & newTextEditor, vbInformation, "TextEditor Example"
    
    ' Reset TextEditor to its original value
    preferences.Files.TextEditor = currTextEditor
    MsgBox "The TextEditor value is reset to " & currTextEditor, vbInformation, "TextEditor Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_TextEditor()
    ;; This example returns the current setting of
    ;; TextEditor. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Retrieve the current TextEditor value
    (setq currTextEditor (vla-get-TextEditor (vla-get-Files preferences)))
    (alert (strcat "The current value for TextEditor is " currTextEditor))
    
    ;; Change the value for TextEditor
    (setq newTextEditor "TestTextEditor")
    (vla-put-TextEditor (vla-get-Files preferences) newTextEditor)
    (alert (strcat "The new value for TextEditor is " newTextEditor))
    
    ;; Reset TextEditor to its original value
    (vla-put-TextEditor (vla-get-Files preferences) currTextEditor)
    (alert (strcat "The TextEditor value is reset to " currTextEditor))
)