AddSpline Method (ActiveX)

Creates a quadratic or cubic NURBS (nonuniform rational B-spline) curve.

Supported platforms: Windows only

Signature

VBA:

RetVal = object.AddSpline(PointsArray, StartTangent, EndTangent)
object

Type: Block, ModelSpace, PaperSpace

The objects this method applies to.

PointsArray

Access: Input-only

Type: Variant (three-element array of doubles)

An array of 3D WCS coordinates defining the spline curve. At least two points (six elements) are required for constructing a Spline object. The array size must be in multiples of three.

StartTangent

Access: Input-only

Type: Variant (three-element array of doubles)

A 3D vector specifying the tangency of the spline curve at the first point.

EndTangent

Access: Input-only

Type: Variant (three-element array of doubles)

A 3D vector specifying the tangency of the spline curve at the last point.

Return Value (RetVal)

Type: Spline

The newly created Spline object.

Remarks

The StartTangent and EndTangent parameters specify the tangents at the two ends of the spline. By default, a spline is created open. The read-only Closed property indicates whether the spline is open or closed.

Examples

VBA:

Sub Example_AddSpline()
    ' This example creates a spline object in model space.

    ' Create the spline
    Dim splineObj As AcadSpline
    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    Dim fitPoints(0 To 8) As Double
    
    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0
    fitPoints(0) = 1: fitPoints(1) = 1: fitPoints(2) = 0
    fitPoints(3) = 5: fitPoints(4) = 5: fitPoints(5) = 0
    fitPoints(6) = 10: fitPoints(7) = 0: fitPoints(8) = 0
    Set splineObj = ThisDrawing.ModelSpace.AddSpline(fitPoints, startTan, endTan)
    ZoomAll
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AddSpline()
    ;; This example creates a spline object in model space.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    ;; Define the spline
    (setq startTan (vlax-3d-point 0.5 0.5 0)
          endTan (vlax-3d-point 0.5 0.5 0))
    (setq fitPoints (vlax-make-safearray vlax-vbDouble '(0 . 8)))
    (vlax-safearray-fill fitPoints '(1 1 0
                                     5 5 0
                                     10 0 0
                                    )
    )
  
    ;; Create the spline
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq splineObj (vla-AddSpline modelSpace fitPoints startTan endTan))
    (vla-ZoomAll acadObj)
)