Saves the document to a specified file; no longer supported for menu groups.
Supported platforms: Windows only
VBA:
object.SaveAs FileName [, FileType] [, SecurityParams]
Type: Document
The object this method applies to.
Access: Input-only
Type: String
The full path and file name, or valid URL address, for the file. The active document takes on the new name.
Access: Input-only; optional
Type: AcSaveAsType enum
Access: Input-only; optional
Type: Variant (a SecurityParams object)
Security settings used to specify a digital signature for the drawing.
VBA:
object.SaveAs MenuFileName, MenuFileType
Type: MenuGroup
The object this method applies to.
Access: Input-only
Type: String
The full path and file name for the menugroup to be saved to.
Access: Input-only
Type: AcMenuFileType enum
No return value.
The default file type for documents is ac2013_dwg. The value acR14_dxf is obsolete.
Documents can be saved only as files with the extensions indicated above. To save a document in a different file type, use the Export method.
When saving to a secure URL, a dialog box prompts the user for the necessary password information. Message boxes appear if the user has not suppressed this activity in the browser.
Menu groups cannot be saved in AutoCAD 2006 and later releases. This method will be removed from the MenuGroup object in a future release.
VBA:
Sub Example_SaveAs() ' The following example saves current drawing as "test.dwg" ThisDrawing.SaveAs "test.dwg" End Sub
Visual LISP:
(defun c:Example_SaveAs() ;; The following example saves current drawing as "test.dwg" (setq acadObj (vlax-get-acad-object)) (setq doc (vla-get-ActiveDocument acadObj)) (vla-SaveAs doc "test.dwg") )