ConfigFile Property (ActiveX)

Gets the location of the configuration file used to store hardware device driver information.

Supported platforms: Windows only

Signature

VBA:

object.ConfigFile
object

Type: PreferencesFiles

The object this property applies to.

Property Value

Read-only: Yes

Type: String

The location of the configuration file used to store hardware device driver information.

Remarks

This value is read-only and can only be changed using the /c command line switch. For more information about command line switches, see the AutoCAD Online help.

Examples

VBA:

Sub Example_ConfigFile()
    ' This example returns the current setting of ConfigFile.
    
    Dim preferences As AcadPreferences
    Dim currConfigFile As String
    
    Set preferences = ThisDrawing.Application.preferences
    
    ' Retrieve the current ConfigFile value
    currConfigFile = preferences.Files.ConfigFile
    If currConfigFile = "" Then
        MsgBox "ConfigFile is not currently set.", vbInformation, "ConfigFile Example"
    Else
        MsgBox "The current value for ConfigFile is " & currConfigFile, vbInformation, "ConfigFile Example"
    End If
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ConfigFile()
    ;; This example returns the current setting of ConfigFile.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
  
    ;; Retrieve the current ConfigFile value
    (setq currConfigFile (vla-get-ConfigFile (vla-get-Files preferences)))
    (if (= currConfigFile "")
        (alert "ConfigFile is not currently set.")
        (alert (strcat "The current value for ConfigFile is " currConfigFile))
    )
)