AddDimAngular Method (ActiveX)

Creates an angular dimension for an arc, two lines, or a circle.

Supported platforms: Windows only

Signature

VBA:

RetVal = object.AddDimAngular(AngleVertex, FirstEndPoint, SecondEndPoint, TextPoint)
object

Type: Block, ModelSpace, PaperSpace

The objects this method applies to.

AngleVertex

Access: Input-only

Type: Variant (three-element array of doubles)

The 3D WCS coordinates specifying the center of the circle or arc, or the common vertex between the two dimensioned lines.

FirstEndPoint

Access: Input-only

Type: Variant (three-element array of doubles)

The 3D WCS coordinates specifying the point through which the first extension line passes.

SecondEndPoint

Access: Input-only

Type: Variant (three-element array of doubles)

The 3D WCS coordinates specifying the point through which the second extension line passes.

TextPoint

Access: Input-only

Type: Variant (three-element array of doubles)

The 3D WCS coordinates specifying the point at which the dimension text is to be displayed.

Return Value (RetVal)

Type: DimAngular

The newly created angular dimension.

Remarks



The AngleVertex is the center of the circle or arc, or the common vertex between the two lines being dimensioned. FirstEndPoint and SecondEndPoint are the points through which the two extension lines pass.

The AngleVertex can be the same as one of the angle endpoints. If you need extension lines, they will be added automatically. The endpoints provided are used as origin points for the extension lines.

Examples

VBA:

Sub Example_AddDimAngular()
    ' This example creates an angular dimension in model space.
    
    Dim dimObj As AcadDimAngular
    Dim angVert(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double
    Dim SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    
    ' Define the dimension
    angVert(0) = 0#: angVert(1) = 5#: angVert(2) = 0#
    FirstPoint(0) = 1#: FirstPoint(1) = 7#: FirstPoint(2) = 0#
    SecondPoint(0) = 1#: SecondPoint(1) = 3#: SecondPoint(2) = 0#
    TextPoint(0) = 3#: TextPoint(1) = 5#: TextPoint(2) = 0#
    
    ' Create the angular dimension in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAngular(angVert, FirstPoint, SecondPoint, TextPoint)
    ZoomAll
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AddDimAngular()
    ;; This example creates an angular dimension in model space.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the dimension
    (setq angVert (vlax-3d-point 0 5 0)
          FirstPoint (vlax-3d-point 1 7 0)
          SecondPoint (vlax-3d-point 1 3 0)
          TextPoint (vlax-3d-point 3 5 0))
  
    ;; Create the angular dimension in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq dimObj (vla-AddDimAngular modelSpace angVert FirstPoint SecondPoint TextPoint))
    (vla-ZoomAll acadObj)
)