LineSpacingStyle Property (ActiveX)

Specifies the line spacing style for the MText object.

Supported platforms: Windows only

Signature

VBA:

object.LineSpacingStyle
object

Type: GeoPositionMarker, MText

The object this property applies to.

Property Value

Read-only: No

Type: acLineSpacingStyle enum

Remarks

The acLineSpacingStyleAtLeast setting allows the spacing between different lines of text to adjust automatically, based on the height of the largest character in a line of text. The acLineSpacingStyleExactly setting forces the line spacing to be the same size for all the lines in the MText object regardless of formatting overrides.

Examples

VBA:

Sub Example_LineSpacingFactor()
    ' This example creates an MText object in model space
    ' and then finds the LineSpacingFactor for the object.
    
    Dim MTextObj As AcadMText
    Dim corner(0 To 2) As Double
    Dim width As Double
    Dim text As String
    corner(0) = 0#: corner(1) = 10#: corner(2) = 0#
    width = 10
    text = "This is the text String for the mtext Object"

    ' Creates the MText Object
    Set MTextObj = ThisDrawing.ModelSpace.AddMText(corner, width, text)
    ZoomAll
    
    ' Find the current LineSpacingFactor
    Dim currFactor As Double
    currFactor = MTextObj.LineSpacingFactor
    MsgBox "The LineSpacingFactor for the MText object is: " & currFactor
    
    ' Change the LineSpacingFactor
    MTextObj.LineSpacingFactor = 4
    MsgBox "The LineSpacingFactor for the MText object is: " & MTextObj.LineSpacingFactor
    
    ' Reset the LineSpacingFactor
    MTextObj.LineSpacingFactor = currFactor
    MsgBox "The LineSpacingFactor for the MText object is: " & MTextObj.LineSpacingFactor
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_LineSpacingFactor()
    ;; This example creates an MText object in model space
    ;; and then finds the LineSpacingFactor for the object.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    (setq corner (vlax-3d-point 0 10 0)
          width 10
          text "This is the text String for the mtext Object")

    ;; Creates the MText Object
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq MTextObj (vla-AddMText modelSpace corner width text))
    (vla-ZoomAll acadObj)
    
    ;; Find the current LineSpacingFactor
    (setq currFactor (vla-get-LineSpacingFactor MTextObj))
    (alert (strcat "The LineSpacingFactor for the MText object is: " (rtos currFactor 2)))
    
    ;; Change the LineSpacingFactor
    (vla-put-LineSpacingFactor MTextObj 0.7)
    (alert (strcat "The LineSpacingFactor for the MText object is: " (rtos (vla-get-LineSpacingFactor MTextObj) 2)))
    
    ;; Reset the LineSpacingFactor
    (vla-put-LineSpacingFactor MTextObj currFactor)
    (alert (strcat "The LineSpacingFactor for the MText object is: " (rtos (vla-get-LineSpacingFactor MTextObj) 2)))
)