MinorAxis Property (ActiveX)

Specifies the direction of the minor axis of an ellipse.

Supported platforms: Windows only

Signature

VBA:

object.MinorAxis
object

Type: Ellipse

The object this property applies to.

Property Value

Read-only: Yes

Type: Variant (three-element array of doubles)

A 3D vector defining the minor axis. The vector originates at the ellipse center.

Remarks

The longer axis of an ellipse is called the major axis; the shorter one is the minor axis.



Examples

VBA:

Sub Example_MinorAxis()
    ' This example creates an ellipse and returns the minor
    ' axis for that ellipse.
    Dim ellObj As AcadEllipse
    Dim majAxis(0 To 2) As Double
    Dim center(0 To 2) As Double
    Dim radRatio As Double
    
    ' Create an ellipse in model space
    center(0) = 5#: center(1) = 5#: center(2) = 0#
    majAxis(0) = 10: majAxis(1) = 20#: majAxis(2) = 0#
    radRatio = 0.3
    Set ellObj = ThisDrawing.ModelSpace.AddEllipse(center, majAxis, radRatio)
    ZoomAll
    
    ' Find the minor axis for the ellipse
    Dim minorAxis As Variant
    minorAxis = ellObj.minorAxis
    MsgBox "The ellipse has a minor axis of " & minorAxis(0) & ", " & minorAxis(1) & ", " & minorAxis(2), vbInformation, "MinorAxis Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_MinorAxis()
    ;; This example creates an ellipse and returns the minor
    ;; axis for that ellipse.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Create an ellipse in model space
    (setq center (vlax-3d-point 5 5 0)
          majAxis (vlax-3d-point 10 20 0)
          radRatio 0.3)

    (setq modelSpace (vla-get-ModelSpace doc))
    (setq ellObj (vla-AddEllipse modelSpace center majAxis radRatio))
    (vla-ZoomAll acadObj)
    
    ;; Find the minor axis for the ellipse
    (setq minorAxis (vlax-variant-value (vla-get-MinorAxis ellObj)))
    (alert (strcat "The ellipse has a minor axis of " (rtos (vlax-safearray-get-element minorAxis 0) 2) ", "
                                                      (rtos (vlax-safearray-get-element minorAxis 1) 2) ", "
                                                      (rtos (vlax-safearray-get-element minorAxis 2) 2)))  
)