Controls the display of raster images during selection.
Supported platforms: Windows only
VBA:
object.ImageFrameHighlight
Type: PreferencesDisplay
The object this property applies to.
Read-only: No
Type: Boolean
The initial value for this property is True.
VBA:
Sub Example_ImageFrameHighlight() ' This example reads and modifies the preference value that controls ' the display of raster images during selection. When finished, this example ' resets the preference value back to its original value. Dim ACADPref As AcadPreferencesDisplay Dim originalValue As Variant, newValue As Variant ' Get the display preferences object Set ACADPref = ThisDrawing.Application.preferences.DISPLAY ' Read and display the original value originalValue = ACADPref.ImageFrameHighlight MsgBox "The ImageFrameHighlight preference is set to: " & originalValue ' Modify the ImageFrameHighlight preference by toggling the value ACADPref.ImageFrameHighlight = Not (originalValue) newValue = ACADPref.ImageFrameHighlight MsgBox "The ImageFrameHighlight preference has been set to: " & newValue ' Reset the preference back to its original value ' ' * Note: Comment out this last section to leave the change to ' this preference in effect ACADPref.ImageFrameHighlight = originalValue MsgBox "The ImageFrameHighlight preference was reset back to: " & originalValue End Sub
Visual LISP:
(vl-load-com) (defun c:Example_ImageFrameHighlight() ;; This example reads and modifies the preference value that controls ;; the display of raster images during selection. When finished, this example ;; resets the preference value back to its original value. (setq acadObj (vlax-get-acad-object)) (setq preferences (vla-get-Preferences acadObj)) ;; Read and display the original value (setq originalValue (vla-get-ImageFrameHighlight (vla-get-Display preferences))) (alert (strcat "The ImageFrameHighlight preference is set to: " (if (= originalValue :vlax-true) "True" "False"))) ;; Modify the ImageFrameHighlight preference by toggling the value (vla-put-ImageFrameHighlight (vla-get-Display preferences) (if (= originalValue :vlax-true) :vlax-false :vlax-true)) (setq newValue (vla-get-ImageFrameHighlight (vla-get-Display preferences))) (alert (strcat "The ImageFrameHighlight preference has been set to: " (if (= newValue :vlax-true) "True" "False"))) ;; Reset the preference back to its original value ;; ;; * Note: Comment out this last section to leave the change to ;; this preference in effect (vla-put-ImageFrameHighlight (vla-get-Display preferences) originalValue) (alert (strcat "The ImageFrameHighlight preference was reset back to: " (if (= originalValue :vlax-true) "True" "False"))) )