FieldCode Method (ActiveX)

Returns a text string containing field codes.

Supported platforms: Windows only

Signature

VBA:

RetVal = object.FieldCode
object

Type: MText, Text

The objects this method applies to.

Return Value (RetVal)

Type: String

The field codes of the object.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_FieldCode()
    ' This example creates a text object in model space.
    ' It then returns the field code string for the object.

    Dim textObj As AcadText
    Dim text As String
    Dim insertionPoint(0 To 2) As Double
    Dim height As Double

    ' Define the text object
    text = "%<\AcVar Date \f ""M/d/yyyy""%>%"
    insertionPoint(0) = 2: insertionPoint(1) = 2: insertionPoint(2) = 0
    height = 0.5
    
    ' Create the text object in model space
    Set textObj = ThisDrawing.ModelSpace.AddText(text, insertionPoint, height)
    ZoomAll
    
    ' Return the current text string for the object
    text = textObj.FieldCode
    MsgBox "The FieldCode for the text object equals: " & text, vbInformation, "FieldCode Example"

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_FieldCode()
    ;; This example creates a text object in model space.
    ;; It then returns the field code string for the object.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    ;; Define the text object
    (setq insertionPoint (vlax-3d-point 2 2 0)
          text "%<\\AcVar Date \\f \"M/d/yyyy\"%>%"
          height 0.5)
    
    ;; Create the text object in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq textObj (vla-AddText modelSpace text insertionPoint height))  
    (vla-ZoomAll acadObj)
    
    ;; Return the current text string for the object
    (setq text (vla-FieldCode textObj))
    (alert (strcat "The FieldCode for the text object equals: " text))
)