ShowWarningMessages Property (ActiveX)

Resets all dialog boxes that have the "Don't Display This Warning Again" check box so they display again.

Supported platforms: Windows only

Signature

VBA:

object.ShowWarningMessages
object

Type: PreferencesSystem

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

The initial value for this property is False.

Examples

VBA:

Sub Example_ShowWarningMessages()
    ' This example reads and modifies the preference value that
    ' resets all dialog boxes that have the
    ' "Don't Display This Warning Again" check box so they display again.
    '
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadPreferencesSystem
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the system preferences object
    Set ACADPref = ThisDrawing.Application.Preferences.System
    
    ' Read and display the original value
    originalValue = ACADPref.ShowWarningMessages
    MsgBox "The ShowWarningMessages preference is set to: " & originalValue

    ' Modify the ShowWarningMessages preference by toggling the value
    ACADPref.ShowWarningMessages = Not (ACADPref.ShowWarningMessages)
    newValue = ACADPref.ShowWarningMessages
    MsgBox "The ShowWarningMessages preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.ShowWarningMessages = originalValue
    MsgBox "The ShowWarningMessages preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ShowWarningMessages()
    ;; This example reads and modifies the preference value that
    ;; resets all dialog boxes that have the
    ;; "Don't Display This Warning Again" check box so they display again.
    ;;
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-ShowWarningMessages (vla-get-System preferences)))
    (alert (strcat "The ShowWarningMessages preference is set to: " (if (= originalValue :vlax-true) "True" "False")))

    ;; Modify the ShowWarningMessages preference by toggling the value
    (vla-put-ShowWarningMessages (vla-get-System preferences) (if (= originalValue :vlax-true) :vlax-false :vlax-true))
    (alert (strcat "The ShowWarningMessages preference has been set to: " (if (= (vla-get-ShowWarningMessages (vla-get-System preferences)) :vlax-true) "True" "False")))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-ShowWarningMessages (vla-get-System preferences) originalValue)
    (alert (strcat "The ShowWarningMessages preference was reset back to: " (if (= (vla-get-ShowWarningMessages (vla-get-System preferences)) :vlax-true) "True" "False")))
)