AutoAudit Property (ActiveX)

Specifies whether AutoCAD should perform an audit after you render a DXFIN or DXBIN interchange command.

Supported platforms: Windows only

Signature

VBA:

object.AutoAudit
object

Type: PreferencesOpenSave

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

No additional remarks.

Examples

VBA:

Sub Example_AutoAudit()
    ' This example returns the current setting of
    ' AutoAudit. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim preferences As AcadPreferences
    Dim currAutoAudit As Boolean
    Dim newAutoAudit As Boolean
    
    Set preferences = ThisDrawing.Application.preferences
    
    ' Retrieve the current AutoAudit value
    currAutoAudit = preferences.OpenSave.AutoAudit
    MsgBox "The current value for AutoAudit is " & currAutoAudit, vbInformation, "AutoAudit Example"
    
    ' Toggle the value for AutoAudit
    newAutoAudit = Not (currAutoAudit)
    preferences.OpenSave.AutoAudit = newAutoAudit
    MsgBox "The new value for AutoAudit is " & newAutoAudit, vbInformation, "AutoAudit Example"
    
    ' Reset AutoAudit to its original value
    preferences.OpenSave.AutoAudit = currAutoAudit
    MsgBox "The AutoAudit value is reset to " & currAutoAudit, vbInformation, "AutoAudit Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AutoAudit()
    ;; This example returns the current setting of
    ;; AutoAudit. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Retrieve the current AutoAudit value
    (setq currAutoAudit (vla-get-AutoAudit (vla-get-OpenSave preferences)))
    (alert (strcat "The current value for AutoAudit is " (if (= currAutoAudit :vlax-true) "True" "False")))
    
    ;; Toggle the value for AutoAudit
    (setq newAutoAudit (if (= currAutoAudit :vlax-true) :vlax-false :vlax-true))
    (vla-put-AutoAudit (vla-get-OpenSave preferences) newAutoAudit)
    (alert (strcat "The new value for AutoAudit is " (if (= newAutoAudit :vlax-true) "True" "False")))
    
    ;; Reset AutoAudit to its original value
    (vla-put-AutoAudit (vla-get-OpenSave preferences) currAutoAudit)
    (alert (strcat "The AutoAudit value is reset to " (if (= currAutoAudit :vlax-true) "True" "False")))
)