AutoSnapMarkerSize Property (ActiveX)

Specifies the size of the AutoSnap marker.

Supported platforms: Windows only

Signature

VBA:

object.AutoSnapMarkerSize
object

Type: PreferencesDrafting

The object this property applies to.

Property Value

Read-only: No

Type: Long

A value from 1 to 20 representing the size of the AutoSnap marker in pixels.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_AutoSnapMarkerSize()
    ' This example reads and modifies the preference value that controls
    ' the size of the AutoSnap marker. When finished, this example resets
    ' the preference value back to its original value.
    
    Dim ACADPref As AcadPreferencesDrafting
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the drafting preferences object
    Set ACADPref = ThisDrawing.Application.preferences.Drafting
    
    ' Read and display the original value
    originalValue = ACADPref.AutoSnapMarkerSize
    MsgBox "The AutoSnapMarkerSize preference is: " & originalValue

    ' Modify the AutoSnapMarkerSize preference by setting it to 10
    ACADPref.AutoSnapMarkerSize = 10
    newValue = ACADPref.AutoSnapMarkerSize
    MsgBox "The AutoSnapMarkerSize preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.AutoSnapMarkerSize = originalValue
    MsgBox "The AutoSnapMarkerSize preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AutoSnapMarkerSize()
    ;; This example reads and modifies the preference value that controls
    ;; the size of the AutoSnap marker. When finished, this example resets
    ;; the preference value back to its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
  
    ;; Get the drafting preferences object
    (setq ACADPref (vla-get-Drafting preferences))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-AutoSnapMarkerSize ACADPref))
    (alert (strcat "The AutoSnapMarkerSize preference is: " (itoa originalValue)))

    ;; Modify the AutoSnapMarkerSize preference by setting it to 10
    (vla-put-AutoSnapMarkerSize ACADPref 10)
    (setq newValue (vla-get-AutoSnapMarkerSize ACADPref))
    (alert (strcat "The AutoSnapMarkerSize preference has been set to: " (itoa newValue)))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-AutoSnapMarkerSize ACADPref originalValue)
    (alert (strcat "The AutoSnapMarkerSize preference was reset back to: " (itoa originalValue)))
)