HelpFilePath Property (ActiveX)

Specifies the location of the AutoCAD Help file.

Supported platforms: Windows only

Signature

VBA:

object.HelpFilePath
object

Type: PreferencesFiles

The object this property applies to.

Property Value

Read-only: No

Type: String

The location of the AutoCAD Help file.

Remarks

This property specifies the drive, path, and file name for the AutoCAD Help file.

Examples

VBA:

Sub Example_HelpFilePath()
    ' This example returns the current setting of
    ' HelpFilePath. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim preferences As AcadPreferences
    Dim currHelpFilePath As String
    Dim newHelpFilePath As String
    Set preferences = ThisDrawing.Application.preferences
    
    ' Retrieve the current HelpFilePath value
    currHelpFilePath = preferences.Files.HelpFilePath
    MsgBox "The current value for HelpFilePath is " & currHelpFilePath, vbInformation, "HelpFilePath Example"
    
    ' Change the value for HelpFilePath
    newHelpFilePath = "C:/AutoCAD/Help"
    preferences.Files.HelpFilePath = newHelpFilePath
    MsgBox "The new value for HelpFilePath is " & newHelpFilePath, vbInformation, "HelpFilePath Example"
    
    ' Reset HelpFilePath to its original value
    preferences.Files.HelpFilePath = currHelpFilePath
    MsgBox "The HelpFilePath value is reset to " & currHelpFilePath, vbInformation, "HelpFilePath Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_HelpFilePath()
    ;; This example returns the current setting of
    ;; HelpFilePath. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Retrieve the current HelpFilePath value
    (setq currHelpFilePath (vla-get-HelpFilePath (vla-get-Files preferences)))
    (alert (strcat "The current value for HelpFilePath is " currHelpFilePath))
    
    ;; Change the value for HelpFilePath
    (setq newHelpFilePath "C:/AutoCAD/Help")
    (vla-put-HelpFilePath (vla-get-Files preferences) newHelpFilePath)
    (alert (strcat "The new value for HelpFilePath is " newHelpFilePath))
    
    ;; Reset HelpFilePath to its original value
    (vla-put-HelpFilePath (vla-get-Files preferences) currHelpFilePath)
    (alert (strcat "The HelpFilePath value is reset to " currHelpFilePath))
)