IAcadObject Interface (ActiveX)

The standard interface for a basic AutoCAD object.

Supported Platforms: Windows only

Class Information

Class Name

AcadObject

Object Inheritance
Object
   AcadObject
Create Using

VBA

ModelSpace.Add<object>
PaperSpace.Add<object>
Block.Add<object>
ModelSpace.AttachExternalReference
PaperSpace.AttachExternalReference
Block.AttachExternalReference
ModelSpace.InsertBlock
PaperSpace.InsertBlock
Block.InsertBlock
Access Via

VBA

ModelSpace.Item
PaperSpace.Item
Block.Item
SelectionSet.Item
Group.Item

Members

These members are part of this object:

Remarks

IAcadObject interface represents the default interface for most AutoCAD objects.

If you are familiar with the ObjectARX environment, you will see that IAcadObject exposes AcDbObject functionality.