ShowProxyDialogBox Property (ActiveX)

Specifies if AutoCAD displays a warning message when you open a drawing that contains custom objects.

Supported platforms: Windows only

Signature

VBA:

object.ShowProxyDialogBox
object

Type: PreferencesOpenSave

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

The initial value of this property is True.

Note: The value of this property is stored in the PROXYNOTICE system variable.

Examples

VBA:

Sub Example_ShowProxyDialogBox()
    ' This example returns the current setting of
    ' ShowProxyDialogBox. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim preferences As AcadPreferences
    Dim currShowProxyDialogBox As Boolean
    
    Set preferences = ThisDrawing.Application.Preferences
    
    ' Retrieve the current ShowProxyDialogBox value
    currShowProxyDialogBox = preferences.OpenSave.ShowProxyDialogBox
    MsgBox "The current value for ShowProxyDialogBox is " & preferences.OpenSave.ShowProxyDialogBox, vbInformation, "ShowProxyDialogBox Example"
    
    ' Change the value for ShowProxyDialogBox
    preferences.OpenSave.ShowProxyDialogBox = Not (currShowProxyDialogBox)
    MsgBox "The new value for ShowProxyDialogBox is " & preferences.OpenSave.ShowProxyDialogBox, vbInformation, "ShowProxyDialogBox Example"
    
    ' Reset ShowProxyDialogBox to its original value
    preferences.OpenSave.ShowProxyDialogBox = currShowProxyDialogBox
    MsgBox "The ShowProxyDialogBox value is reset to " & preferences.OpenSave.ShowProxyDialogBox, vbInformation, "ShowProxyDialogBox Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ShowProxyDialogBox()
    ;; This example returns the current setting of
    ;; ShowProxyDialogBox. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Retrieve the current ShowProxyDialogBox value
    (setq currShowProxyDialogBox (vla-get-ShowProxyDialogBox (vla-get-OpenSave preferences)))
    (alert (strcat "The current value for ShowProxyDialogBox is " (if (= currShowProxyDialogBox :vlax-true) "True" "False")))
    
    ;; Change the value for ShowProxyDialogBox
    (vla-put-ShowProxyDialogBox (vla-get-OpenSave preferences) (if (= currShowProxyDialogBox :vlax-true) :vlax-false :vlax-true))
    (alert (strcat "The new value for ShowProxyDialogBox is " (if (= (vla-get-ShowProxyDialogBox (vla-get-OpenSave preferences)) :vlax-true) "True" "False")))
    
    ;; Reset ShowProxyDialogBox to its original value
    (vla-put-ShowProxyDialogBox (vla-get-OpenSave preferences) currShowProxyDialogBox)
    (alert (strcat "The ShowProxyDialogBox value is reset to " (if (= (vla-get-ShowProxyDialogBox (vla-get-OpenSave preferences)) :vlax-true) "True" "False")))
)