IsQuiescent Property (ActiveX)

Checks whether AutoCAD is idle and ready to accept automation calls from out-of-process applications.

Supported platforms: Windows only

Signature

VBA:

object.IsQuiescent
object

Type: State

The object this property applies to.

Property Value

Read-only: Yes

Type: Boolean

Remarks

No additional remarks.

Examples

VBA:

Sub Example_IsQuiescent()
    ' This example gets the acadState object and checks to see whether
    ' AutoCAD is in a quiescent state.
    Dim State As AcadState
    Set State = GetAcadState

    If State.IsQuiescent Then
        MsgBox "AutoCAD is quiescent."
    Else
        MsgBox "AutoCAD is not quiescent."
    End If
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_IsQuiescent()
    ;; This example gets the acadState object and checks to see if
    ;; AutoCAD is in a quiescent state.
    (setq acadObj (vlax-get-acad-object))
  
    (setq State (vla-GetAcadState acadObj))
    (if (= (vla-get-IsQuiescent State) :vlax-true)
        (alert "AutoCAD is quiescent.")
        (alert "AutoCAD is not quiescent.")
    )
)