MRUNumber Property (ActiveX)

Specifies the number of most recently used files that is shown in the File menu.

Supported platforms: Windows only

Signature

VBA:

object.MRUNumber
object

Type: PreferencesOpenSave

The object this property applies to.

Property Value

Read-only: Yes

Type: Long

The number of most recently used files that is shown in the File menu.

Remarks

The default value for this property is 4.

Examples

VBA:

Sub Example_MRUNumber()
    ' This example reads the preference value containing
    ' the number of most recently used files that are shown in the File menu.
    
    Dim ACADPref As AcadPreferencesOpenSave
    Dim originalValue As Variant
    
    ' Get the OpenSave preferences object
    Set ACADPref = ThisDrawing.Application.preferences.OpenSave
    
    ' Read and display the preference value
    originalValue = ACADPref.MRUNumber
    MsgBox "The number of most recently used files that are shown is: " & originalValue

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_MRUNumber()
    ;; This example reads the preference value containing
    ;; the number of most recently used files that are shown in the File menu.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Get the OpenSave preferences object
    (setq ACADPref (vla-get-OpenSave preferences))
    
    ;; Read and display the preference value
    (setq originalValue (vla-get-MRUNumber ACADPref))
    (alert (strcat "The number of most recently used files that are shown is: " (itoa originalValue)))
)