Verify Property (ActiveX)

Specifies if the attribute is set for verification.

Supported platforms: Windows only

Signature

VBA:

object.Verify
object

Type: Attribute

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

An attribute set to verify prompts the user for verification that the attribute value is correct when inserting the block.

An attribute may exist as only one of four optional modes: constant, preset, invisible, or verify. The AFLAGS system variable stores the current mode settings. You can query the current mode using the Mode property.

Examples

VBA:

Sub Example_Verify()
    ' This example creates an attribute definition in model space.
    ' It then sets the definition to be verify, and queries the mode.
    
    Dim attributeObj As AcadAttribute
    Dim height As Double
    Dim mode As Long
    Dim prompt As String
    Dim insertionPoint(0 To 2) As Double
    Dim tag As String
    Dim value As String
    
    ' Define the attribute definition
    height = 1#
    mode = acAttributeModeVerify
    prompt = "New Prompt"
    insertionPoint(0) = 5#: insertionPoint(1) = 5#: insertionPoint(2) = 0
    tag = "New_Tag"
    value = "New Value"
    
    ' Create the attribute definition object in model space
    Set attributeObj = ThisDrawing.ModelSpace.AddAttribute(height, mode, prompt, insertionPoint, tag, value)
    ZoomAll
    
    ' Change the mode to be verify
    attributeObj.mode = acAttributeModeVerify
    attributeObj.Update
    
    ' Check to see if the attribute is set to verify
    MsgBox (IIf(attributeObj.Verify, "The attribute is set to verify", "The attribute is not set to verify"))
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Verify()
    ;; This example creates an attribute definition in model space.
    ;; It then sets the definition to be verify, and queries the mode.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the attribute definition
    (setq insertionPoint (vlax-3d-point 5 5 0)
          attHeight 1
          attMode acAttributeModeVerify
          attPrompt "New Prompt"
          attTag "New_Tag"
          attValue "New Value")
    
    ;; Create the attribute definition object in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq attributeObj (vla-AddAttribute modelSpace attHeight attMode attPrompt insertionPoint attTag attValue))
    (vla-ZoomAll acadObj)
    
    ;; Change the mode to be verify
    (vla-put-Mode attributeObj acAttributeModeVerify)
    (vla-Update attributeObj)
    
    ;; Check to see if the attribute is set to verify
    (alert (if (= (vla-get-Verify attributeObj) :vlax-true) "The attribute is set to verify" "The attribute is not set to verify"))
)