SetPattern Method (ActiveX)

Sets the pattern name and pattern type for the hatch.

Supported platforms: Windows only

Signature

VBA:

object.SetPattern PatternType, PatternName
object

Type: Hatch

The object this method applies to.

PatternType

Access: Input-only

Type: AcPatternType enum

  • acHatchPatternTypePreDefined: Selects the pattern name from those defined in the acad.pat file.
  • acHatchPatternTypeUserDefined: Defines a pattern of lines using the current linetype.
  • acHatchPatternTypeCustomDefined: Selects the pattern name from a PAT file other than the acad.pat file.
PatternName

Access: Input-only

Type: String

The name of the pattern. Sets a default hatch pattern name of up to 34 characters, no spaces allowed. Returns "" if there is no default. Enter a period (.) to set no default.

Return Value (RetVal)

No return value.

Remarks

The hatch pattern can be defined by one of the following options:

PreDefined: Selects the pattern name from those defined in the acad.pat file.

UserDefined: Defines a pattern of lines using the current linetype.

CustomDefined: Selects the pattern name from a PAT file other than the acad.pat file.

Note: The SetPattern method should only be used for the active document.

Examples

VBA:

Sub Example_SetPattern()
    ' This example creates an associative hatch in model space.
    ' The hatch pattern is then changed.
    
    Dim hatchObj As AcadHatch
    Dim patternName As String
    Dim PatternType As Long
    Dim bAssociativity As Boolean
    
    ' Define the hatch
    patternName = "ANSI31"
    PatternType = 0
    bAssociativity = True
    
    ' Create the associative Hatch object
    Set hatchObj = ThisDrawing.ModelSpace.AddHatch(PatternType, patternName, bAssociativity)
    
    ' Create the outer loop for the hatch.
    ' An arc and a line are used to create a closed loop.
    
    Dim outerLoop(0 To 1) As AcadEntity
    Dim center(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double
    Dim endAngle As Double
    center(0) = 5: center(1) = 3: center(2) = 0
    radius = 3
    startAngle = 0
    endAngle = 3.141592
    Set outerLoop(0) = ThisDrawing.ModelSpace.AddArc(center, radius, startAngle, endAngle)
    Set outerLoop(1) = ThisDrawing.ModelSpace.AddLine(outerLoop(0).startPoint, outerLoop(0).endPoint)
        
    ' Append the outer loop to the hatch object
    hatchObj.AppendOuterLoop (outerLoop)
    
    ' Append the first circle as one inner loop
    Dim innerLoop1(0) As AcadEntity
    center(0) = 5: center(1) = 4.5: center(2) = 0
    radius = 1
    Set innerLoop1(0) = ThisDrawing.ModelSpace.AddCircle(center, radius)
    hatchObj.AppendInnerLoop (innerLoop1)
    
    ' Append the second circle as the other inner loop
    Dim innerLoop2(0) As AcadEntity
    radius = 0.5
    Set innerLoop2(0) = ThisDrawing.ModelSpace.AddCircle(center, radius)
    hatchObj.AppendInnerLoop (innerLoop2)
    
    ' Evaluate and display the hatch
    hatchObj.Evaluate
    ZoomAll
    
    ' Find the name of the hatch pattern
    patternName = hatchObj.patternName
    MsgBox "The hatch pattern is " & hatchObj.patternName, , "SetPattern Example"
                   
    ' Change the hatch pattern
    hatchObj.SetPattern acHatchPatternTypePreDefined, "BRICK"
    hatchObj.Evaluate
    ThisDrawing.Regen True
    MsgBox "The hatch pattern is now " & hatchObj.patternName, , "SetPattern Example"
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_SetPattern()
    ;; This example creates an associative hatch in model space.
    ;; The hatch pattern is then changed.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    ;; Define the hatch
    (setq patternName "ANSI31"
          patternType 0
          bAssociativity :vlax-true)
    
    ;; Create the associative Hatch object
    (setq modelSpace (vla-get-ModelSpace doc))  
    (setq hatchObj (vla-AddHatch modelSpace patternType patternName bAssociativity acHatchObject))
    
    ;; Create the outer loop for the hatch.
    ;; An arc and a line are used to create a closed loop.
    (setq center (vlax-3d-point 5 3 0) 
          radius 3
          startAngle 0
          endAngle 3.141592)
  
    (setq arc (vla-AddArc modelSpace center radius startAngle endAngle))
    (setq line (vla-AddLine modelSpace (vla-get-StartPoint arc) (vla-get-EndPoint arc)))
  
    (setq outerLoop (vlax-make-safearray vlax-vbObject '(0 . 1)))
    (vlax-safearray-put-element outerLoop 0 arc)
    (vlax-safearray-put-element outerLoop 1 line)
        
    ;; Append the outer loop to the hatch object
    (vla-AppendOuterLoop hatchObj outerLoop)
    
    ;; Append the first circle as one inner loop
    (setq center (vlax-3d-point 5 4.5 0)  
          radius 1)
    (setq circle1 (vla-AddCircle modelSpace center radius))

    (setq innerLoop1 (vlax-make-safearray vlax-vbObject '(0 . 0)))
    (vlax-safearray-put-element innerLoop1 0 circle1)

    (vla-AppendInnerLoop hatchObj innerLoop1)
    
    ;; Append the second circle as the other inner loop
    (setq radius 0.5)
    (setq innerLoop2 (vlax-make-safearray vlax-vbObject '(0 . 0)))
    (setq circle2 (vla-AddCircle modelSpace center radius))
    (vlax-safearray-put-element innerLoop2 0 circle2)

    (vla-AppendInnerLoop hatchObj innerLoop2)
    
    ;; Evaluate and display the hatch
    (vla-Evaluate hatchObj)
    (vla-ZoomAll acadObj)
    
    ;; Find the name of the hatch pattern
    (setq patternName (vla-get-patternName hatchObj))
    (alert (strcat "The hatch pattern is " patternName))
                   
    ;; Change the hatch pattern
    (vla-SetPattern hatchObj acHatchPatternTypePreDefined "BRICK")
    (vla-Evaluate hatchObj)
    (vla-Regen doc :vlax-true)
    (alert (strcat "The hatch pattern is now " (vla-get-patternName hatchObj)))
)