EndLISP Event (ActiveX)

Triggered upon completion of evaluating an AutoLISP expression.

Supported platforms: Windows only

Signature

VBA:

object.EndLISP()
object

Type: Application, Document

An object expression that evaluates to a valid container object. In this case, the only valid containers are the application and a document.

Remarks

This event will occur after either a normal termination of the AutoLISP evaluation, or after a cancellation of the AutoLISP evaluation.

No events will be fired while a modal dialog is being displayed.

Examples

VBA:

Private Sub AcadDocument_EndLisp()
    ' This example intercepts a drawing BeginLisp event.
    '
    ' This event is triggered when a drawing finishes
    ' a the evaluation of a LISP expression.
    '
    ' To trigger this example event: Start the evaluation of a LISP expression and
    ' wait for it to finish being evaluated

    MsgBox "A LISP expression has just finished being evaluated!"

End Sub

Visual LISP:

Not available