LayoutDisplayMargins Property (ActiveX)

Toggles the display of margins in layouts.

Supported platforms: Windows only

Signature

VBA:

object.LayoutDisplayMargins
object

Type: PreferencesDisplay

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

The initial value for this property is True.

Examples

VBA:

Sub Example_LayoutDisplayMargins()
    ' This example reads and modifies the preference value that controls
    ' the display of margins in layouts. When finished, this example
    ' resets the preference value back to its original value.
    
    Dim ACADPref As AcadPreferencesDisplay
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the display preferences object
    Set ACADPref = ThisDrawing.Application.Preferences.Display
    
    ' Switch to paper space to view this change
    ThisDrawing.ActiveSpace = acPaperSpace
    
    ' Read and display the original value
    originalValue = ACADPref.LayoutDisplayMargins
    MsgBox "The LayoutDisplayMargins preference is set to: " & originalValue

    ' Modify the LayoutDisplayMargins preference by toggling the value
    ACADPref.LayoutDisplayMargins = Not (originalValue)
    newValue = ACADPref.LayoutDisplayMargins
    ThisDrawing.Regen acAllViewports
    
    MsgBox "The LayoutDisplayMargins preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.LayoutDisplayMargins = originalValue
    ThisDrawing.Regen acAllViewports
    
    MsgBox "The LayoutDisplayMargins preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_LayoutDisplayMargins()
    ;; This example reads and modifies the preference value that controls
    ;; the display of margins in layouts. When finished, this example
    ;; resets the preference value back to its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Switch to paper space to view this change
    (vla-put-ActiveSpace doc acPaperSpace)
    
    ;; Read and display the original value
    (setq originalValue (vla-get-LayoutDisplayMargins (vla-get-Display preferences)))
    (alert (strcat "The LayoutDisplayMargins preference is set to: " (if (= originalValue :vlax-true) "True"  "False")))

    ;; Modify the LayoutDisplayMargins preference by toggling the value
    (vla-put-LayoutDisplayMargins (vla-get-Display preferences) (if (= originalValue :vlax-true) :vlax-false :vlax-true))
    (setq newValue (vla-get-LayoutDisplayMargins (vla-get-Display preferences)))
    (vla-Regen doc acAllViewports)

    (alert (strcat "The LayoutDisplayMargins preference has been set to: " (if (= newValue :vlax-true) "True"  "False")))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-LayoutDisplayMargins (vla-get-Display preferences) originalValue)
    (vla-Regen doc acAllViewports)
    
    (alert (strcat "The LayoutDisplayMargins preference was reset back to: " (if (= originalValue :vlax-true) "True"  "False")))
)