TrueColor Property (ActiveX)

Specifies the True Color of an object.

Supported platforms: Windows only

Signature

VBA:

object.TrueColor
object

Type: All drawing objects, AttributeReference, Dimension, Group, Layer

The objects this property applies to.

Property Value

Read-only: No

Type: AcCmColor

The True Color object of the object.

Remarks

This property is used to change an object's color. Colors are identified by an AcCmColor object. This object can hold an RGB value, an ACI number (an integer from 1 to 255), or a named color. Using an RGB value, you can choose from millions of colors.

Examples

VBA:

Sub Example_TrueColor()
    ' This example draws a line and returns the RGB values
    Dim color As AcadAcCmColor
    Set color = AcadApplication.GetInterfaceObject("AutoCAD.AcCmColor." & Left(AcadApplication.Version, 2))
    color.SetRGB 80, 100, 244
    
    Dim line As AcadLine
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double
        
    startPoint(0) = 1#: startPoint(1) = 1#: startPoint(2) = 0#
    endPoint(0) = 5#: endPoint(1) = 5#: endPoint(2) = 0#
        
    Set line = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)
    ZoomAll
    
    line.TrueColor = color
    Dim retcolor As AcadAcCmColor
    Set retcolor = line.TrueColor
    
    MsgBox "Red = " & retcolor.Red & vbLf & _
           "Green = " & retcolor.Green & vbLf & _
           "Blue = " & retcolor.Blue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_TrueColor()
    ;; This example draws a line and returns the RGB values
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    (setq color (vlax-create-object (strcat "AutoCAD.AcCmColor." (substr (getvar "ACADVER") 1 2))))
    (vla-SetRGB color 80 100 244)
    
    (setq startPoint (vlax-3d-point 1 1 0)
          endPoint (vlax-3d-point 5 5 0))

    (setq modelSpace (vla-get-ModelSpace doc))
    (setq lineObj (vla-AddLine modelSpace startPoint endPoint))
    (vla-ZoomAll acadObj)
    
    (vla-put-TrueColor lineObj color)
    (setq retcolor (vla-get-TrueColor lineObj))
    
    (alert (strcat "Red = " (itoa (vla-get-Red retcolor))
                   "\nGreen = " (itoa (vla-get-Green retcolor))
                   "\nBlue = " (itoa (vla-get-Blue retcolor))))
)